<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://thesportsdaily.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="The results of the rookie survey were released recently and both of the Timberwolves 2018 draft picks were mentioned. Okogie was picked second by his peers as the rookie who is most athletic and picked third as the best defender." />
<meta name="keywords" content="timberwolves, josh okogie, kieta bates-diop, minnesota timberwolves, nba, rookie, timberwolves" />
<title>Which Timberwolves Rookie will have the Biggest Immediate Impact? | The Sports Daily</title>
<meta name="google-site-verification" content="7pIhL37xPn0j2ice9LpmhGvYLzV7tt4b3ISDIHLcnlc" />
<meta name="msvalidate.01" content="A503EAA776DF2DC7A0BF5452FABD2A26" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=thesportsdaily.com&amp;id=142507471&amp;t=1535922537&amp;back=https%3A%2F%2Fthesportsdaily.com%2F2018%2F09%2F02%2Fwhich-rookie-will-have-the-greatest-immediate-impact%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//tags.tiqcdn.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//admin.brightcove.com' />
<link rel='dns-prefetch' href='//thesportsdailydigital.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Sports Daily &raquo; Feed" href="http://thesportsdaily.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Sports Daily &raquo; Comments Feed" href="http://thesportsdaily.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Sports Daily &raquo; Which Timberwolves Rookie will have the Biggest Immediate Impact? Comments Feed" href="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1532082729h&ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJyNUNtOwzAM/SFCmMa4PCA+Y89ualKvThzV6ar+PemqggYj4iXysc8ltp2ScRIzxmzDaBKPnqLaKTkJRgMxzj/QvVO9s7dlTD2qPWFO4HpzQTW6kwFLPyTICyNgS4CModBqspCeNtVSdiWrGrN+v2nSgKqmvIHGYHJXgn7r1rY9U7KjQpYW5i8jzeT62VBkimjO1KKUJfT24F/ODNOA0eE2PIJCQ9VlqPWYS6Q4AjZUKNdgFZONktfhVtRcPYphcZBJ4hUwHww01KQDNiy+lP5yim/41wG6R+tZGuCF8B7edof9/uF5d3h9OX0CznP2GA==?cssminify=yes' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script type='text/javascript'>
/* <![CDATA[ */
var amznAcctId = ["3090"];
/* ]]> */
</script>
<script type='text/javascript'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId, adServer: "googletag"});
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyFjt0KwjAMRl/Irm7DCy/EZ8naOFPXH5t2ZT69HeiFOBQCgeTk5JMlCHJqyhpZmlr3jHF5tcbwTv4ChKUxQsLGknvDyruELq2s9QNNKDJjhLHOqujiN7jgOVlkrtDG9jMSuZmw/MUMpgDqJiIyPb6s6Yr1n5wpyMyQvIZFTFAiOoWrayCtMQoLrkaK9fpsT+2h79p91x578wTGP3Mx'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var utag_data = {"ssts":"","priority_asset":"","blogname":"","videoincluded":"no","platform":"desktop","contenttype":"story pages","assetid":"840780","headline":"Which Timberwolves Rookie will have the Biggest Immediate Impact?","byline":"Aaron Herbst","taxonomykeywords":"Josh Okogie, Kieta Bates-Diop, Minnesota Timberwolves, NBA, rookie, Timberwolves"};
/* ]]> */
</script>
<script type='text/javascript'>
			utag_data.clickPage = sessionStorage.getItem( "clickPage" );
			sessionStorage.setItem( "clickPage", window.location.href );
			
</script>
<script type='text/javascript' src='https://tags.tiqcdn.com/utag/gci/sportsdaily/prod/utag.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var usatoday_gallery_ajax_object = {"publisherGA":"UA-83608810-1","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-83608810-1","dfpid":"7103","pid":"SMG_TheSportsDaily","ads":{"poster":"\/7103\/SMG_TheSportsDaily\/300x250_1g\/sports\/general","tablet":"\/7103\/SMG_TheSportsDaily\/728x90_1gt\/sports\/general"},"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/sportsdaily\/prod\/utag.js"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var stickyInlineVideosOptions = {"side":"right"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJylkE0SwiAMRi9kZGin48rxLAhpDaUUG2jt7cX6s3Ih4y7zJe9NErEE0KOP6KOIFxyQxUxBJFZxNGqF4FJHnoUKBJ1yDifKI4oZIwvLIqJylIZXb91b3ok/lYlNyPmSWzDLfVXi5Ei6X4G8I48wk8Fxc37Lf/E6tUzoNW6OngJkvod21ImhpVupwl7T40mDIl+KOjq/8ecxxeuTmT6GXGf+NBxlIw91U0lZ2zviH8Ul'></script>
<script type='text/javascript' src='http://admin.brightcove.com/js/BrightcoveExperiences.js?ver=4.9.8'></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1530132353h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thesportsdailydigital.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://usat.ly/2PXPloP' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fthesportsdaily.com%2F2018%2F09%2F02%2Fwhich-rookie-will-have-the-greatest-immediate-impact%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fthesportsdaily.com%2F2018%2F09%2F02%2Fwhich-rookie-will-have-the-greatest-immediate-impact%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Which Timberwolves Rookie will have the Biggest Immediate Impact?" />
<meta property="og:url" content="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/" />
<meta property="og:description" content="The results of the rookie survey were released recently and both of the Timberwolves 2018 draft picks were mentioned. Okogie was picked second by his peers as the rookie who is most athletic and pi…" />
<meta property="article:published_time" content="2018-09-02T19:41:15+00:00" />
<meta property="article:modified_time" content="2018-09-02T20:13:57+00:00" />
<meta property="og:site_name" content="The Sports Daily" />
<meta property="og:image" content="https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10929421.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@sportsdailyblog" />
<meta name="twitter:text:title" content="Which Timberwolves Rookie will have the Biggest Immediate Impact?" />
<meta name="twitter:image" content="https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10929421.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/SportsDailyBlog/" />

<!-- End Jetpack Open Graph Tags -->
<link rel="search" type="application/opensearchdescription+xml" href="http://thesportsdaily.com/osd.xml" title="The Sports Daily" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />

<meta name="gdpr" content="false" />
<style type="text/css">
.articleBody a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.widget--box .text-block > h2,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title {
	color: #eb1e00;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #eb1e00;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #eb1e00;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #eb1e00;
}

.nav__item:hover,
.nav__item--current,
#footer-info {
	border-top-color: #eb1e00;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #eb1e00;
}

.article__back,
.newsletter__input,
.daily-newsletter__input {
	border-color: #eb1e00;
}

.vertical-gallery--icon,
.smg-event--icon,
.vertical-gallery__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.newsletter__button,
.daily-newsletter__button {
	background-color: #eb1e00;
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #eb1e00;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #eb1e00;
	}
}

.smg-event__ctabutton {
	background-color: #eb1e00;
	box-shadow: 0 2px 0 0 #eb1e00;
}
</style>
<link rel="canonical" href="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
		<meta name="application-name" content="The Sports Daily" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Sports news, viral videos, rumors and analysis—without the hot takes!" /><meta name="msapplication-task" content="name=Subscribe;action-uri=http://thesportsdaily.com/feed/;icon-uri=https://thesportsdailydigital.files.wordpress.com/2018/03/cropped-icon-large.png?w=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>
window.dfpTargetingObject = {"kw":["Josh Okogie","Kieta Bates-Diop","Minnesota Timberwolves","NBA","rookie","Timberwolves","Aaron Herbst"],"category":"Timberwolves","referrer":"","isMobile":"0"};
	dfpTargetingObject.level2adunit = "SMG_TheSportsDaily";
	googletag_cmd_push(function() {
window.lawrence_dfp_desktop_skin = googletag.defineSlot("/7103/SMG_TheSportsDaily/skin/sports/general", [1,1], "acm-ad-tag-lawrence_dfp_desktop_skin").addService(googletag.pubads().setTargeting('kw',["Josh Okogie","Kieta Bates-Diop","Minnesota Timberwolves","NBA","rookie","Timberwolves","Aaron Herbst"]).setTargeting('category',["Timberwolves"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["skin"]);window.lawrence_dfp_desktop_interstitial = googletag.defineSlot("/7103/SMG_TheSportsDaily/interstitial/sports/general", [2,1], "acm-ad-tag-lawrence_dfp_desktop_interstitial").addService(googletag.pubads().setTargeting('kw',["Josh Okogie","Kieta Bates-Diop","Minnesota Timberwolves","NBA","rookie","Timberwolves","Aaron Herbst"]).setTargeting('category',["Timberwolves"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["interstitial"]);window.lawrence_dfp_desktop_top = googletag.defineSlot("/7103/SMG_TheSportsDaily/728x90_flex/sports/general", ['fluid',[728,90],[970,66],[970,250]], "acm-ad-tag-lawrence_dfp_desktop_top").addService(googletag.pubads().setTargeting('kw',["Josh Okogie","Kieta Bates-Diop","Minnesota Timberwolves","NBA","rookie","Timberwolves","Aaron Herbst"]).setTargeting('category',["Timberwolves"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["728x90_flex"]);window.lawrence_dfp_desktop_top_300x250 = googletag.defineSlot("/7103/SMG_TheSportsDaily/300x250_1a/sports/general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_top_300x250").addService(googletag.pubads().setTargeting('kw',["Josh Okogie","Kieta Bates-Diop","Minnesota Timberwolves","NBA","rookie","Timberwolves","Aaron Herbst"]).setTargeting('category',["Timberwolves"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_1a"]);window.lawrence_dfp_desktop_gallery_poster = googletag.defineSlot("/7103/SMG_TheSportsDaily/300x250_1g/sports/general", ['fluid',[300,250]], "acm-ad-tag-lawrence_dfp_desktop_gallery_poster").addService(googletag.pubads().setTargeting('kw',["Josh Okogie","Kieta Bates-Diop","Minnesota Timberwolves","NBA","rookie","Timberwolves","Aaron Herbst"]).setTargeting('category',["Timberwolves"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_1g"]);window.lawrence_dfp_desktop_outstream = googletag.defineSlot("/7103/SMG_TheSportsDaily/outstream/sports/general", [4,1], "acm-ad-tag-lawrence_dfp_desktop_outstream").addService(googletag.pubads().setTargeting('kw',["Josh Okogie","Kieta Bates-Diop","Minnesota Timberwolves","NBA","rookie","Timberwolves","Aaron Herbst"]).setTargeting('category',["Timberwolves"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["outstream"]);window.wasabiAsyncStickAd = false;
if ( ! window.hasOwnProperty( 'wasabiAsyncStickCallback' ) ) {
	window.wasabiAsyncStickCallback = function() {
		'use strict';
		window.wasabiAsyncStickAd = true;
	};
}
googletag.pubads().enableSingleRequest();

googletag.pubads().collapseEmptyDivs();
googletag.enableServices();

bidManager.initialize();
});
</script>
<link rel="amphtml" href="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>
<link rel="icon" href="https://thesportsdailydigital.files.wordpress.com/2018/03/cropped-icon-large.png?w=32" sizes="32x32" />
<link rel="icon" href="https://thesportsdailydigital.files.wordpress.com/2018/03/cropped-icon-large.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://thesportsdailydigital.files.wordpress.com/2018/03/cropped-icon-large.png?w=180" />
<meta name="msapplication-TileImage" content="https://thesportsdailydigital.files.wordpress.com/2018/03/cropped-icon-large.png?w=270" />
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s2.wp.com/?custom-css=1&#038;csblog=9DWHB&#038;cscache=6&#038;csrev=20" />
		
	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-840780 single-format-standard mp6 customizer-styles-applied single-post--section highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_interstitial' style='width:2px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_interstitial'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
	
<div id="wrapper">

	
	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding branding--section"
	id="nav-branding"
	style="background-image: url( 'https://thesportsdailydigital.files.wordpress.com/2018/03/1howlintwolf.png' );"
>
	<span class="branding__logos">
					<a
				href="http://thesportsdaily.com"
				title="The Sports Daily"
				class="branding__logo-link branding__logo-link--home"
			>
				<img
					src="https://thesportsdailydigital.files.wordpress.com/2018/03/icon-small.png"
					alt="The Sports Daily"
					class="branding__logo"
					height="30"
									style="max-height: 45px"
								>
			</a>
		
					<a
				href="http://thesportsdaily.com/category/howlin-t-wolf/"
				title="The Sports Daily"
				class="branding__logo-link branding__logo-link--section"
			>
				<span class="branding__section">Timberwolves</span>
			</a>
			</span>

	
	<span class="branding__search">
		<form method="get" class="branding__search-form" action="http://thesportsdaily.com" role="search">
			<input type="text" name="s" value="" placeholder="search The Sports Daily" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-795225" class="nav__item nav__item--nfl nav__item--parent"><a href="http://thesportsdaily.com/category/nfl/">NFL</a>
<ul class="sub-menu">
	<li id="menu-item-795235" class="nav__item nav__item--afc-east nav__item--parent"><a href="#">AFC East</a>
	<ul class="sub-menu">
		<li id="menu-item-795240" class="nav__item nav__item--dolphins"><a href="http://thesportsdaily.com/category/phins-phocus/">Dolphins</a></li>
		<li id="menu-item-795241" class="nav__item nav__item--jets"><a href="http://thesportsdaily.com/category/new-york-sack-exchange/">Jets</a></li>
		<li id="menu-item-795242" class="nav__item nav__item--patriots"><a href="http://thesportsdaily.com/category/foxboro-blog/">Patriots</a></li>
	</ul>
</li>
	<li id="menu-item-795236" class="nav__item nav__item--afc-north nav__item--parent"><a href="#">AFC North</a>
	<ul class="sub-menu">
		<li id="menu-item-795247" class="nav__item nav__item--bengals"><a href="http://thesportsdaily.com/category/bengals-brigade/">Bengals</a></li>
		<li id="menu-item-795248" class="nav__item nav__item--browns"><a href="http://thesportsdaily.com/category/browns-pound/">Browns</a></li>
		<li id="menu-item-795249" class="nav__item nav__item--ravens"><a href="http://thesportsdaily.com/category/ravens-football-machine/">Ravens</a></li>
		<li id="menu-item-832113" class="nav__item nav__item--steelers"><a href="http://thesportsdaily.com/category/pittsburgh-steelers/">Steelers</a></li>
	</ul>
</li>
	<li id="menu-item-795237" class="nav__item nav__item--afc-south nav__item--parent"><a href="#">AFC South</a>
	<ul class="sub-menu">
		<li id="menu-item-795251" class="nav__item nav__item--colts"><a href="http://thesportsdaily.com/category/colts-authority/">Colts</a></li>
		<li id="menu-item-795252" class="nav__item nav__item--jaguars"><a href="http://thesportsdaily.com/category/the-jaggernaut/">Jaguars</a></li>
		<li id="menu-item-795253" class="nav__item nav__item--texans"><a href="http://thesportsdaily.com/category/texans-tribune/">Texans</a></li>
		<li id="menu-item-795254" class="nav__item nav__item--titans"><a href="http://thesportsdaily.com/category/total-titans/">Titans</a></li>
	</ul>
</li>
	<li id="menu-item-795238" class="nav__item nav__item--afc-west nav__item--parent"><a href="#">AFC West</a>
	<ul class="sub-menu">
		<li id="menu-item-795255" class="nav__item nav__item--broncos"><a href="http://thesportsdaily.com/category/mile-high-broncos/">Broncos</a></li>
		<li id="menu-item-795561" class="nav__item nav__item--chargers"><a href="http://thesportsdaily.com/category/the-bolts-blog/">Chargers</a></li>
		<li id="menu-item-795258" class="nav__item nav__item--chiefs"><a href="http://thesportsdaily.com/category/chiefs-daily/">Chiefs</a></li>
		<li id="menu-item-795259" class="nav__item nav__item--raiders"><a href="http://thesportsdaily.com/category/tfds-sports/">Raiders</a></li>
	</ul>
</li>
	<li id="menu-item-795243" class="nav__item nav__item--nfc-east nav__item--parent"><a href="#">NFC East</a>
	<ul class="sub-menu">
		<li id="menu-item-795450" class="nav__item nav__item--cowboys"><a href="http://thesportsdaily.com/category/dallas-cowboys/">Cowboys</a></li>
		<li id="menu-item-795261" class="nav__item nav__item--eagles"><a href="http://thesportsdaily.com/category/eagles-eye-blog/">Eagles</a></li>
		<li id="menu-item-831778" class="nav__item nav__item--giants"><a href="http://thesportsdaily.com/category/new-york-giants/">Giants</a></li>
		<li id="menu-item-795263" class="nav__item nav__item--redskins"><a href="http://thesportsdaily.com/category/redskins-hog-heaven/">Redskins</a></li>
	</ul>
</li>
	<li id="menu-item-795244" class="nav__item nav__item--nfc-north nav__item--parent"><a href="#">NFC North</a>
	<ul class="sub-menu">
		<li id="menu-item-795265" class="nav__item nav__item--bears"><a href="http://thesportsdaily.com/category/soldier-field-salute/">Bears</a></li>
		<li id="menu-item-795266" class="nav__item nav__item--lions"><a href="http://thesportsdaily.com/category/outside-the-lions/">Lions</a></li>
		<li id="menu-item-795264" class="nav__item nav__item--packers"><a href="http://thesportsdaily.com/category/packers-press/">Packers</a></li>
		<li id="menu-item-795267" class="nav__item nav__item--vikings"><a href="http://thesportsdaily.com/category/vikings-digital-diaries/">Vikings</a></li>
	</ul>
</li>
	<li id="menu-item-795245" class="nav__item nav__item--nfc-south nav__item--parent"><a href="#">NFC South</a>
	<ul class="sub-menu">
		<li id="menu-item-802362" class="nav__item nav__item--buccaneers"><a href="http://thesportsdaily.com/category/tampa-bay-buccaneers/">Buccaneers</a></li>
		<li id="menu-item-795268" class="nav__item nav__item--falcons"><a href="http://thesportsdaily.com/category/grits-blitz/">Falcons</a></li>
		<li id="menu-item-795271" class="nav__item nav__item--panthers"><a href="http://thesportsdaily.com/category/panther-rules/">Panthers</a></li>
		<li id="menu-item-795270" class="nav__item nav__item--saints"><a href="http://thesportsdaily.com/category/the-saints-nation/">Saints</a></li>
	</ul>
</li>
	<li id="menu-item-795246" class="nav__item nav__item--nfc-west nav__item--parent"><a href="#">NFC West</a>
	<ul class="sub-menu">
		<li id="menu-item-795273" class="nav__item nav__item--49ers"><a href="http://thesportsdaily.com/category/the-red-and-gold/">49ers</a></li>
		<li id="menu-item-795274" class="nav__item nav__item--cardinals"><a href="http://thesportsdaily.com/category/cardinals-camp/">Cardinals</a></li>
		<li id="menu-item-795275" class="nav__item nav__item--rams"><a href="http://thesportsdaily.com/category/rams-ramblings/">Rams</a></li>
		<li id="menu-item-795272" class="nav__item nav__item--seahawks"><a href="http://thesportsdaily.com/category/seahawk-addicts/">Seahawks</a></li>
	</ul>
</li>
	<li id="menu-item-811498" class="nav__item nav__item--general nav__item--parent"><a href="#">General</a>
	<ul class="sub-menu">
		<li id="menu-item-811497" class="nav__item nav__item--guru-qb"><a href="http://thesportsdaily.com/category/guru-qb/">Guru QB</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-802346" class="nav__item nav__item--nba nav__item--parent"><a href="http://thesportsdaily.com/category/nba/">NBA</a>
<ul class="sub-menu">
	<li id="menu-item-795282" class="nav__item nav__item--featured nav__item--parent"><a href="#">FEATURED</a>
	<ul class="sub-menu">
		<li id="menu-item-820537" class="nav__item nav__item--cowbell-kingdom"><a href="http://thesportsdaily.com/category/cowbell-kingdom/">Cowbell Kingdom</a></li>
		<li id="menu-item-795304" class="nav__item nav__item--reds-army"><a href="http://thesportsdaily.com/category/reds-army/">Red's Army</a></li>
	</ul>
</li>
	<li id="menu-item-795276" class="nav__item nav__item--atlantic nav__item--parent"><a href="#">Atlantic</a>
	<ul class="sub-menu">
		<li id="menu-item-795356" class="nav__item nav__item--76ers"><a href="http://thesportsdaily.com/category/philadelphia-76ers/">76ers</a></li>
		<li id="menu-item-802347" class="nav__item nav__item--celtics"><a href="http://thesportsdaily.com/category/boston-celtics/">Celtics</a></li>
		<li id="menu-item-795447" class="nav__item nav__item--knicks"><a href="http://thesportsdaily.com/category/new-york-knicks/">Knicks</a></li>
		<li id="menu-item-795305" class="nav__item nav__item--nets"><a href="http://thesportsdaily.com/category/brooklyn-balling/">Nets</a></li>
		<li id="menu-item-795355" class="nav__item nav__item--raptors"><a href="http://thesportsdaily.com/category/hoop-heads-north/">Raptors</a></li>
	</ul>
</li>
	<li id="menu-item-795277" class="nav__item nav__item--central nav__item--parent"><a href="#">Central</a>
	<ul class="sub-menu">
		<li id="menu-item-795362" class="nav__item nav__item--bucks"><a href="http://thesportsdaily.com/category/milwaukee-bucks/">Bucks</a></li>
		<li id="menu-item-795363" class="nav__item nav__item--bulls"><a href="http://thesportsdaily.com/category/chicago-bulls/">Bulls</a></li>
		<li id="menu-item-795366" class="nav__item nav__item--cavaliers"><a href="http://thesportsdaily.com/category/cleveland-cavaliers/">Cavaliers</a></li>
		<li id="menu-item-795312" class="nav__item nav__item--pacers"><a href="http://thesportsdaily.com/category/pacers-pulse/">Pacers</a></li>
		<li id="menu-item-795390" class="nav__item nav__item--pistons"><a href="http://thesportsdaily.com/category/detroit-pistons/">Pistons</a></li>
	</ul>
</li>
	<li id="menu-item-795278" class="nav__item nav__item--southeast nav__item--parent"><a href="#">Southeast</a>
	<ul class="sub-menu">
		<li id="menu-item-795374" class="nav__item nav__item--hawks"><a href="http://thesportsdaily.com/category/atlanta-hawks/">Hawks</a></li>
		<li id="menu-item-795375" class="nav__item nav__item--heat"><a href="http://thesportsdaily.com/category/miami-heat/">Heat</a></li>
		<li id="menu-item-795315" class="nav__item nav__item--hornets"><a href="http://thesportsdaily.com/category/trade-street-post/">Hornets</a></li>
		<li id="menu-item-795380" class="nav__item nav__item--magic"><a href="http://thesportsdaily.com/category/orlando-magic/">Magic</a></li>
		<li id="menu-item-805978" class="nav__item nav__item--wizards"><a href="http://thesportsdaily.com/category/hoop-district/">Wizards</a></li>
	</ul>
</li>
	<li id="menu-item-795279" class="nav__item nav__item--northwest nav__item--parent"><a href="#">Northwest</a>
	<ul class="sub-menu">
		<li id="menu-item-795377" class="nav__item nav__item--jazz"><a href="http://thesportsdaily.com/category/utah-jazz/">Jazz</a></li>
		<li id="menu-item-795386" class="nav__item nav__item--nuggets"><a href="http://thesportsdaily.com/category/denver-nuggets/">Nuggets</a></li>
		<li id="menu-item-795401" class="nav__item nav__item--thunder"><a href="http://thesportsdaily.com/category/oklahoma-city-thunder/">Thunder</a></li>
		<li id="menu-item-795309" class="nav__item nav__item--timberwolves"><a href="http://thesportsdaily.com/category/howlin-t-wolf/">Timberwolves</a></li>
		<li id="menu-item-795403" class="nav__item nav__item--trailblazers"><a href="http://thesportsdaily.com/category/portland-trailblazers/">Trailblazers</a></li>
	</ul>
</li>
	<li id="menu-item-795280" class="nav__item nav__item--southwest nav__item--parent"><a href="#">Southwest</a>
	<ul class="sub-menu">
		<li id="menu-item-795372" class="nav__item nav__item--grizzlies"><a href="http://thesportsdaily.com/category/memphis-grizzlies/">Grizzlies</a></li>
		<li id="menu-item-795383" class="nav__item nav__item--mavericks"><a href="http://thesportsdaily.com/category/dallas-mavericks/">Mavericks</a></li>
		<li id="menu-item-795313" class="nav__item nav__item--pelicans"><a href="http://thesportsdaily.com/category/pelicans-eye-view/">Pelicans</a></li>
		<li id="menu-item-795393" class="nav__item nav__item--rockets"><a href="http://thesportsdaily.com/category/houston-rockets/">Rockets</a></li>
		<li id="menu-item-795396" class="nav__item nav__item--spurs"><a href="http://thesportsdaily.com/category/san-antonio-spurs/">Spurs</a></li>
	</ul>
</li>
	<li id="menu-item-795281" class="nav__item nav__item--pacific nav__item--parent"><a href="#">Pacific</a>
	<ul class="sub-menu">
		<li id="menu-item-795449" class="nav__item nav__item--clippers"><a href="http://thesportsdaily.com/category/los-angeles-clippers/">Clippers</a></li>
		<li id="menu-item-828095" class="nav__item nav__item--kings"><a href="http://thesportsdaily.com/category/cow-town-hoops/">Kings</a></li>
		<li id="menu-item-795378" class="nav__item nav__item--lakers"><a href="http://thesportsdaily.com/category/los-angeles-lakers/">Lakers</a></li>
		<li id="menu-item-795397" class="nav__item nav__item--suns"><a href="http://thesportsdaily.com/category/phoenix-suns/">Suns</a></li>
		<li id="menu-item-795311" class="nav__item nav__item--warriors"><a href="http://thesportsdaily.com/category/lets-go-warriors/">Warriors</a></li>
	</ul>
</li>
	<li id="menu-item-795290" class="nav__item nav__item--general nav__item--parent"><a href="#">General</a>
	<ul class="sub-menu">
		<li id="menu-item-795376" class="nav__item nav__item--hoops-manifesto"><a href="http://thesportsdaily.com/category/hoops-manifesto/">Hoops Manifesto</a></li>
		<li id="menu-item-795314" class="nav__item nav__item--the-lottery-mafia"><a href="http://thesportsdaily.com/category/the-lottery-mafia/">The Lottery Mafia</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-795227" class="nav__item nav__item--mlb nav__item--parent"><a href="http://thesportsdaily.com/category/mlb/">MLB</a>
<ul class="sub-menu">
	<li id="menu-item-812963" class="nav__item nav__item--featured nav__item--parent"><a href="#">FEATURED</a>
	<ul class="sub-menu">
		<li id="menu-item-812964" class="nav__item nav__item--pirates-breakdown"><a href="http://thesportsdaily.com/category/pirates-breakdown/">Pirates Breakdown</a></li>
	</ul>
</li>
	<li id="menu-item-795283" class="nav__item nav__item--al-east nav__item--parent"><a href="#">AL East</a>
	<ul class="sub-menu">
		<li id="menu-item-795360" class="nav__item nav__item--blue-jays"><a href="http://thesportsdaily.com/category/toronto-blue-jays/">Blue Jays</a></li>
		<li id="menu-item-795387" class="nav__item nav__item--orioles"><a href="http://thesportsdaily.com/category/baltimore-orioles/">Orioles</a></li>
		<li id="menu-item-795392" class="nav__item nav__item--rays"><a href="http://thesportsdaily.com/category/tampa-bay-rays/">Rays</a></li>
		<li id="menu-item-795371" class="nav__item nav__item--red-sox"><a href="http://thesportsdaily.com/category/fenway-west/">Red Sox</a></li>
		<li id="menu-item-795406" class="nav__item nav__item--yankees"><a href="http://thesportsdaily.com/category/new-york-yankees/">Yankees</a></li>
	</ul>
</li>
	<li id="menu-item-795284" class="nav__item nav__item--al-central nav__item--parent"><a href="#">AL Central</a>
	<ul class="sub-menu">
		<li id="menu-item-795364" class="nav__item nav__item--indians"><a href="http://thesportsdaily.com/category/burning-river-baseball/">Indians</a></li>
		<li id="menu-item-795395" class="nav__item nav__item--royals"><a href="http://thesportsdaily.com/category/kansas-city-royals/">Royals</a></li>
		<li id="menu-item-795402" class="nav__item nav__item--tigers"><a href="http://thesportsdaily.com/category/detriot-tigers/">Tigers</a></li>
		<li id="menu-item-795404" class="nav__item nav__item--twins"><a href="http://thesportsdaily.com/category/twins-target/">Twins</a></li>
		<li id="menu-item-795405" class="nav__item nav__item--white-sox"><a href="http://thesportsdaily.com/category/grab-some-bench/">White Sox</a></li>
	</ul>
</li>
	<li id="menu-item-795285" class="nav__item nav__item--al-west nav__item--parent"><a href="#">AL West</a>
	<ul class="sub-menu">
		<li id="menu-item-795357" class="nav__item nav__item--angels"><a href="http://thesportsdaily.com/category/angels-win/">Angels</a></li>
		<li id="menu-item-795358" class="nav__item nav__item--astros"><a href="http://thesportsdaily.com/category/houston-astros/">Astros</a></li>
		<li id="menu-item-795359" class="nav__item nav__item--athletics"><a href="http://thesportsdaily.com/category/oakland-athletics/">Athletics</a></li>
		<li id="menu-item-795381" class="nav__item nav__item--mariners"><a href="http://thesportsdaily.com/category/seattle-mariners/">Mariners</a></li>
		<li id="menu-item-795391" class="nav__item nav__item--rangers"><a href="http://thesportsdaily.com/category/texas-rangers/">Rangers</a></li>
	</ul>
</li>
	<li id="menu-item-795286" class="nav__item nav__item--nl-east nav__item--parent"><a href="#">NL East</a>
	<ul class="sub-menu">
		<li id="menu-item-795361" class="nav__item nav__item--braves"><a href="http://thesportsdaily.com/category/atlanta-braves/">Braves</a></li>
		<li id="menu-item-795382" class="nav__item nav__item--marlins"><a href="http://thesportsdaily.com/category/miami-marlins/">Marlins</a></li>
		<li id="menu-item-795384" class="nav__item nav__item--mets"><a href="http://thesportsdaily.com/category/metstradamus-blog/">Mets</a></li>
		<li id="menu-item-795385" class="nav__item nav__item--nationals"><a href="http://thesportsdaily.com/category/washington-nationals/">Nationals</a></li>
		<li id="menu-item-795379" class="nav__item nav__item--phillies"><a href="http://thesportsdaily.com/category/macho-row/">Phillies</a></li>
	</ul>
</li>
	<li id="menu-item-795287" class="nav__item nav__item--nl-central nav__item--parent"><a href="#">NL Central</a>
	<ul class="sub-menu">
		<li id="menu-item-795399" class="nav__item nav__item--brewers"><a href="http://thesportsdaily.com/category/the-brewers-bar/">Brewers</a></li>
		<li id="menu-item-795365" class="nav__item nav__item--cardinals"><a href="http://thesportsdaily.com/category/cards-diaspora/">Cardinals</a></li>
		<li id="menu-item-795368" class="nav__item nav__item--cubs"><a href="http://thesportsdaily.com/category/chicago-cubs/">Cubs</a></li>
		<li id="menu-item-811481" class="nav__item nav__item--pirates"><a href="http://thesportsdaily.com/category/pirates-breakdown/">Pirates</a></li>
		<li id="menu-item-795398" class="nav__item nav__item--reds"><a href="http://thesportsdaily.com/category/redleg-baseball/">Reds</a></li>
	</ul>
</li>
	<li id="menu-item-795288" class="nav__item nav__item--nl-west nav__item--parent"><a href="#">NL West</a>
	<ul class="sub-menu">
		<li id="menu-item-795369" class="nav__item nav__item--diamondbacks"><a href="http://thesportsdaily.com/category/arizona-diamondbacks/">Diamondbacks</a></li>
		<li id="menu-item-795370" class="nav__item nav__item--dodgers"><a href="http://thesportsdaily.com/category/los-angeles-dodgers/">Dodgers</a></li>
		<li id="menu-item-795400" class="nav__item nav__item--giants"><a href="http://thesportsdaily.com/category/the-giants-cove/">Giants</a></li>
		<li id="menu-item-795388" class="nav__item nav__item--padres"><a href="http://thesportsdaily.com/category/san-diego-padres/">Padres</a></li>
		<li id="menu-item-795394" class="nav__item nav__item--rockies"><a href="http://thesportsdaily.com/category/colorado-rockies/">Rockies</a></li>
	</ul>
</li>
	<li id="menu-item-795289" class="nav__item nav__item--general nav__item--parent"><a href="#">General</a>
	<ul class="sub-menu">
		<li id="menu-item-795367" class="nav__item nav__item--chin-music-baseball"><a href="http://thesportsdaily.com/category/chin-music-baseball/">Chin Music Baseball</a></li>
		<li id="menu-item-795373" class="nav__item nav__item--hall-of-very-good"><a href="http://thesportsdaily.com/category/hall-of-very-good/">Hall of Very Good</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-795228" class="nav__item nav__item--nhl nav__item--parent"><a href="http://thesportsdaily.com/category/nhl/">NHL</a>
<ul class="sub-menu">
	<li id="menu-item-795295" class="nav__item nav__item--featured nav__item--parent"><a href="#">FEATURED</a>
	<ul class="sub-menu">
		<li id="menu-item-795411" class="nav__item nav__item--the-pensblog"><a href="http://thesportsdaily.com/category/the-pensblog/">The Pensblog</a></li>
		<li id="menu-item-795419" class="nav__item nav__item--the-oilers-rig"><a href="http://thesportsdaily.com/category/the-oilers-rig/">The Oilers Rig</a></li>
	</ul>
</li>
	<li id="menu-item-795291" class="nav__item nav__item--atlantic nav__item--parent"><a href="#">Atlantic</a>
	<ul class="sub-menu">
		<li id="menu-item-795451" class="nav__item nav__item--sabres"><a href="http://thesportsdaily.com/category/buffalo-sabres/">Sabres</a></li>
		<li id="menu-item-795409" class="nav__item nav__item--senators"><a href="http://thesportsdaily.com/category/the-6th-sens/">Senators</a></li>
	</ul>
</li>
	<li id="menu-item-795292" class="nav__item nav__item--metropolitan nav__item--parent"><a href="#">Metropolitan</a>
	<ul class="sub-menu">
		<li id="menu-item-795412" class="nav__item nav__item--blue-jackets"><a href="http://thesportsdaily.com/category/buckeye-state-hockey/">Blue Jackets</a></li>
		<li id="menu-item-795413" class="nav__item nav__item--devils"><a href="http://thesportsdaily.com/category/running-with-the-devils/">Devils</a></li>
		<li id="menu-item-795415" class="nav__item nav__item--islanders"><a href="http://thesportsdaily.com/category/islanders-insight/">Islanders</a></li>
		<li id="menu-item-795421" class="nav__item nav__item--penguins"><a href="http://thesportsdaily.com/category/the-pensblog/">Penguins</a></li>
		<li id="menu-item-795414" class="nav__item nav__item--rangers"><a href="http://thesportsdaily.com/category/ny-rangers-blog/">Rangers</a></li>
	</ul>
</li>
	<li id="menu-item-795293" class="nav__item nav__item--central nav__item--parent"><a href="#">Central</a>
	<ul class="sub-menu">
		<li id="menu-item-795417" class="nav__item nav__item--blues"><a href="http://thesportsdaily.com/category/frozen-notes/">Blues</a></li>
		<li id="menu-item-795416" class="nav__item nav__item--wild"><a href="http://thesportsdaily.com/category/crease-and-assist/">Wild</a></li>
	</ul>
</li>
	<li id="menu-item-795294" class="nav__item nav__item--pacific nav__item--parent"><a href="#">Pacific</a>
	<ul class="sub-menu">
		<li id="menu-item-795418" class="nav__item nav__item--kings"><a href="http://thesportsdaily.com/category/the-hockey-kings/">Kings</a></li>
		<li id="menu-item-795420" class="nav__item nav__item--oilers"><a href="http://thesportsdaily.com/category/the-oilers-rig/">Oilers</a></li>
	</ul>
</li>
	<li id="menu-item-795296" class="nav__item nav__item--general nav__item--parent"><a href="#">General</a>
	<ul class="sub-menu">
		<li id="menu-item-795422" class="nav__item nav__item--barry-melrose-rocks"><a href="http://thesportsdaily.com/category/barry-melrose-rocks/">Barry Melrose Rocks</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-832243" class="nav__item nav__item--combat nav__item--parent"><a href="http://thesportsdaily.com/category/combat/">COMBAT</a>
<ul class="sub-menu">
	<li id="menu-item-795299" class="nav__item nav__item--mma nav__item--parent"><a href="http://thesportsdaily.com/category/mma/">MMA</a>
	<ul class="sub-menu">
		<li id="menu-item-795302" class="nav__item nav__item--mma-manifesto"><a href="http://thesportsdaily.com/category/mma-manifesto/">MMA Manifesto</a></li>
		<li id="menu-item-795428" class="nav__item nav__item--undercard-superstar"><a href="http://thesportsdaily.com/category/undercard-superstar/">Undercard Superstar</a></li>
	</ul>
</li>
	<li id="menu-item-795424" class="nav__item nav__item--pro-wrestling nav__item--parent"><a href="#">PRO WRESTLING</a>
	<ul class="sub-menu">
		<li id="menu-item-830408" class="nav__item nav__item--the-floor-seat"><a href="http://thesportsdaily.com/category/the-floor-seat/">The Floor Seat</a></li>
		<li id="menu-item-795427" class="nav__item nav__item--from-the-top-rope"><a href="http://thesportsdaily.com/category/from-the-top-rope/">From the Top Rope</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-812119" class="nav__item nav__item--more nav__item--parent"><a href="#">MORE</a>
<ul class="sub-menu">
	<li id="menu-item-830229" class="nav__item nav__item--culture"><a href="http://thesportsdaily.com/category/culture/">CULTURE</a></li>
	<li id="menu-item-795425" class="nav__item nav__item--media nav__item--parent"><a href="#">MEDIA</a>
	<ul class="sub-menu">
		<li id="menu-item-795430" class="nav__item nav__item--fangs-bites"><a href="http://thesportsdaily.com/category/fangs-bites/">Fang's Bites</a></li>
	</ul>
</li>
	<li id="menu-item-795229" class="nav__item nav__item--ncaa nav__item--parent"><a href="http://thesportsdaily.com/category/ncaa/">NCAA</a>
	<ul class="sub-menu">
		<li id="menu-item-795300" class="nav__item nav__item--north-dakota"><a href="http://thesportsdaily.com/category/goonsworld-blog/">North Dakota</a></li>
		<li id="menu-item-795423" class="nav__item nav__item--penn-state"><a href="http://thesportsdaily.com/category/nittany-lions-den/">Penn State</a></li>
	</ul>
</li>
	<li id="menu-item-795429" class="nav__item nav__item--racing"><a href="http://thesportsdaily.com/category/unexpected-pitstop/">RACING</a></li>
	<li id="menu-item-795233" class="nav__item nav__item--soccer"><a href="http://thesportsdaily.com/category/soccer/">SOCCER</a></li>
	<li id="menu-item-830232" class="nav__item nav__item--sports-betting"><a href="http://thesportsdaily.com/category/gambling/">SPORTS BETTING</a></li>
	<li id="menu-item-795431" class="nav__item nav__item--regional nav__item--parent"><a href="#">REGIONAL</a>
	<ul class="sub-menu">
		<li id="menu-item-795432" class="nav__item nav__item--left-coast-sports"><a href="http://thesportsdaily.com/category/left-coast-sports/">Left Coast Sports</a></li>
		<li id="menu-item-830418" class="nav__item nav__item--motor-city-daily"><a href="http://thesportsdaily.com/category/motor-city-daily/">Motor City Daily</a></li>
		<li id="menu-item-795434" class="nav__item nav__item--total-sports-live"><a href="http://thesportsdaily.com/category/total-sports-live/">Total Sports Live</a></li>
		<li id="menu-item-795433" class="nav__item nav__item--t-town-sports"><a href="http://thesportsdaily.com/category/t-town-sports/">T Town Sports</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-795298" class="nav__item nav__item--contact nav__item--parent"><a href="http://thesportsdaily.com/contact-the-sports-daily/">CONTACT</a>
<ul class="sub-menu">
	<li id="menu-item-795297" class="nav__item nav__item--about"><a href="https://thesportsdaily.com/the-sports-daily-staff/">ABOUT</a></li>
	<li id="menu-item-803162" class="nav__item nav__item--advertise"><a href="http://thesportsdaily.com/advertise-2/">ADVERTISE</a></li>
	<li id="menu-item-803163" class="nav__item nav__item--write-for-us"><a href="http://thesportsdaily.com/interested-in-joining-the-sports-daily-network/">WRITE FOR US</a></li>
	<li id="menu-item-804113" class="nav__item nav__item--partner-sites nav__item--parent"><a href="#">PARTNER SITES</a>
	<ul class="sub-menu">
		<li id="menu-item-804114" class="nav__item nav__item--bloguin-media-group"><a href="http://bloguin.com">Bloguin Media Group</a></li>
		<li id="menu-item-804115" class="nav__item nav__item--sports-media-101"><a href="http://sportsmedia101.com">Sports Media 101</a></li>
		<li id="menu-item-804116" class="nav__item nav__item--boston-sports-extra"><a href="http://bostonsportsextra.com">Boston Sports Extra</a></li>
	</ul>
</li>
</ul>
</li>
		</ul>
		<ul class="nav__social nav__social--section">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="https://www.facebook.com/SportsDailyBlog/" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/SportsDailyBlog" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main no-more-heroes">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-840780" class="post-840780 post type-post status-publish format-standard has-post-thumbnail hentry category-howlin-t-wolf tag-josh-okogie tag-kieta-bates-diop tag-minnesota-timberwolves tag-nba tag-rookie tag-howlin-t-wolf" itemscope
				itemtype="http://schema.org/NewsArticle">

				<div class="article__title ">
	<h1 class="article__headline">Which Timberwolves Rookie will have the Biggest Immediate Impact?</h1>

			<img width="1000" height="600" src="https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10929421.jpg?w=1000&amp;h=600&amp;crop=1" class="article__image wp-post-image" alt="" srcset="https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10929421.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10929421.jpg?w=2000&amp;h=1200&amp;crop=1 2000w, https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10929421.jpg?w=150&amp;h=90&amp;crop=1 150w, https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10929421.jpg?w=300&amp;h=180&amp;crop=1 300w, https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10929421.jpg?w=768&amp;h=461&amp;crop=1 768w, https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10929421.jpg?w=1024&amp;h=614&amp;crop=1 1024w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="840781" data-permalink="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/nba-summer-league-brooklyn-nets-at-minnesota-timberwolves-3/" data-orig-file="https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10929421.jpg" data-orig-size="2400,1800" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Stephen R. Sylvanie-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D5&quot;,&quot;caption&quot;:&quot;Jul 9, 2018; Las Vegas, NV, USA; Minnesota Timberwolves guard Josh Okogie (20) dribbles during the second half against the Brooklyn Nets at Cox Pavilion. Mandatory Credit: Stephen R. Sylvanie-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1531170432&quot;,&quot;copyright&quot;:&quot;Stephen R. Sylvanie&quot;,&quot;focal_length&quot;:&quot;120&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.001&quot;,&quot;title&quot;:&quot;NBA: Summer League-Brooklyn Nets at Minnesota Timberwolves&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NBA: Summer League-Brooklyn Nets at Minnesota Timberwolves" data-image-description="" data-medium-file="https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10929421.jpg?w=300" data-large-file="https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10929421.jpg?w=1000" />		<cite class="article__source"></cite>
		<div class="article__gradient"></div>
	</div>
<h1 class="article__headline article__headline--mobile">Which Timberwolves Rookie will have the Biggest Immediate Impact?</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="http://thesportsdaily.com/category/howlin-t-wolf/" class="" itemprop="articleSection">Timberwolves</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Which Timberwolves Rookie will have the Biggest Immediate Impact?</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p itemprop="author" itemscope itemtype="http://schema.org/Person">

	By <a href="http://thesportsdaily.com/author/aaherbst/" title="Posts by Aaron Herbst" class="author url fn" rel="author">Aaron Herbst</a> 
		<span class="post-date updated">September 2, 2018</span>

	
	</p>
					</div>

					
				</header>

				
				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count"></span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/"
		data-short-url="https://usat.ly/2PXPloP"
		data-track="storyfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/"
		data-short-url="https://usat.ly/2PXPloP"
		data-track="storytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="sportsdailyblog"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/"
		data-short-url="https://usat.ly/2PXPloP"
		data-track="storypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/"
		data-short-url="https://usat.ly/2PXPloP"
		data-track="storysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/"
		data-short-url="https://usat.ly/2PXPloP"
		data-track="storywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/"
			data-short-url="https://usat.ly/2PXPloP"
			data-track="storyemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p itemprop="author" itemscope itemtype="http://schema.org/Person">
		By: <a href="http://thesportsdaily.com/author/aaherbst/" title="Posts by Aaron Herbst" class="author url fn" rel="author">Aaron Herbst</a>		| September 2, 2018		<span class="article__author__widgets">
								</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><p><span style="font-weight:400;">The results of the </span><a href="http://www.nba.com/2018-19-nba-rookie-survey"><span style="font-weight:400;">rookie survey</span></a><span style="font-weight:400;"> were released recently and both of the Timberwolves 2018 draft picks were mentioned. Okogie was picked second by his peers as the rookie who is most athletic and picked third as the best defender. Keita Bates-Diop wasn&#8217;t excluded as he was selected as the biggest steal of the draft. Both draft picks are very talented in their own ways, but who will make the most immediate impact for the Wolves this season?</span></p>
<p><span style="font-weight:400;">Hot take coming in: Probably the first round pick will make the greatest impact. But keep in mind that the Wolves were thinking of taking KBD with the 20th pick instead of Okogie. And the fact that he slipped all the way to 48 shocked everyone in the Wolves war room.</span></p>
<p><span style="font-weight:400;">“We were very surprised he was still there,” Thibodeau said. “We liked him a lot. He did a great job when he came in with his workout, and with his interview. And [he had] a great season with Ohio State.”</span></p>
<p><span style="font-weight:400;">Many draft analysts had him going in the late first round or early second round, including the Wolves, so it’s unlikely that Thibs will show any favoritism to either prospect as some head coaches do with their higher draft picks. </span></p>
<p><span style="font-weight:400;">Having said that, Okogie offers far more upside as a player than KBD does. Okogie’s defensive activity and lateral quickness jump right off the screen when you watch him. His ability to get around screens and disrupt defenders is an absolute joy to watch. Not to mention his uncanny ability to time up and block shots. A physical freak with an unrelenting motor, Okogie is the quintessential ‘Thibs guy’.</span></p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='1000' height='563' src='https://www.youtube.com/embed/zYh0wDYbYiE?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p><span style="font-weight:400;">But there is a scenario that if you squint really hard with me, you may also see it. And that scenario is where Thibs finds he needs more shooting with the second unit and KBD finds a role and thrives in it. Okogie, while having substantially more upside than KBD, isn’t as NBA ready as KBD&#8211;as we saw with him winning the Big Ten Player of the Year last season.</span></p>
<p><span style="font-weight:400;">The only game tape against pros that anyone has seen of either prospect has been in summer league. Both showed out really well, but Okogie did not look comfortable from behind the arc. Bates-Diop, however, looked like the stretch 4 that could help contribute with Anthony Tolliver after the departure of Nemanja Bjelica. </span></p>
<p><span style="font-weight:400;">KBD has some drawbacks defensively but was able to make up for it with his massive 7-foot-3 wingspan during summer league.</span></p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='1000' height='563' src='https://www.youtube.com/embed/Er7rRso-lFg?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p><span style="font-weight:400;">The athletes he saw in summer league won’t be on the same level as the ones he’ll see when he plays against the likes of LeBron James, Russell Westbrook or Anthony Davis. However, KBD thinks his experience in college may set him apart from his fellow rookies. </span></p>
<p><span style="font-weight:400;">“I have maturity over some guys from my four years. I have an edge on a lot of the younger guys who are still teenagers. I’ve been through a lot already,” Bates-Diop said. </span></p>
<p><span style="font-weight:400;">That maturity along with a three-point shot may be enough to earn him some minutes this season. Thibs is notorious for playing his starters heavy minutes, which in turn means fewer minutes for the second string and no minutes for the third string. My best guess is Bates-Diop plays a lot in the G-League this first season and will get called up sparingly if an injury arises. But if he takes advantage of his minutes by bringing a defensive intensity and the three-pointer we’ve seen, he may, in fact, find a nice little niche on the Timberwolves roster.</span></p>
</div>

						
						
						<p class="post-tags post-tags--hide"><a href="http://thesportsdaily.com/tag/josh-okogie/" rel="tag">Josh Okogie</a>, <a href="http://thesportsdaily.com/tag/kieta-bates-diop/" rel="tag">Kieta Bates-Diop</a>, <a href="http://thesportsdaily.com/tag/minnesota-timberwolves/" rel="tag">Minnesota Timberwolves</a>, <a href="http://thesportsdaily.com/tag/nba/" rel="tag">NBA</a>, <a href="http://thesportsdaily.com/tag/rookie/" rel="tag">rookie</a>, <a href="http://thesportsdaily.com/tag/howlin-t-wolf/" rel="tag">Timberwolves</a>, <a href="http://thesportsdaily.com/category/howlin-t-wolf/" rel="category tag">Timberwolves</a></p>
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count"></span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/"
		data-short-url="https://usat.ly/2PXPloP"
		data-track="storyfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/"
		data-short-url="https://usat.ly/2PXPloP"
		data-track="storytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="sportsdailyblog"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/"
		data-short-url="https://usat.ly/2PXPloP"
		data-track="storypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/"
		data-short-url="https://usat.ly/2PXPloP"
		data-track="storysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/"
		data-short-url="https://usat.ly/2PXPloP"
		data-track="storywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/"
			data-short-url="https://usat.ly/2PXPloP"
			data-track="storyemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>Recent <span>News</span></h2>
	</div>
	
		<div class="holder-column">
			<div class="column">
				
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
			<a href="https://thesportsdaily.com/2018/08/12/the-national-medias-perception-of-the-wolves-is-perplexing/" data-track="featuredstories" title="The National Media&#039;s Perception of the Wolves is... Perplexing" class="link fixed-height-img-holder short responsiveshort " rel="nofollow" style="background-image: url('https://thesportsdailydigital.files.wordpress.com/2018/08/usatsi_10781721.jpg?w=295&#038;h=231&#038;crop=1');" itemprop="url" >
			<img src="https://thesportsdailydigital.files.wordpress.com/2018/08/usatsi_10781721.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="The National Media&#039;s Perception of the Wolves is... Perplexing" itemprop="image">
						<span class="ie-overlay-hack"></span>
								</a>
	
	<div class="text-block ">
		<h2>
			<a href="http://thesportsdaily.com/category/howlin-t-wolf/" class="category" itemprop="articleSection">Timberwolves</a>					</h2>

		<p><a data-track="featuredstories" href="https://thesportsdaily.com/2018/08/12/the-national-medias-perception-of-the-wolves-is-perplexing/" title="The National Media&#039;s Perception of the Wolves is... Perplexing" itemprop="url" >The National Media&#039;s Perception of the Wolves is... Perplexing</a></p>

			</div>
</article>

<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
			<a href="https://thesportsdaily.com/2018/08/30/ten-nfl-training-camp-battles-won-by-rookies/" data-track="featuredstories" title="Ten NFL Training Camp Battles Won By Rookies" class="link fixed-height-img-holder short responsiveshort " rel="nofollow" style="background-image: url('https://thesportsdailydigital.files.wordpress.com/2018/08/usatsi_11124409.jpg?w=295&#038;h=231&#038;crop=1');" itemprop="url" >
			<img src="https://thesportsdailydigital.files.wordpress.com/2018/08/usatsi_11124409.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Ten NFL Training Camp Battles Won By Rookies" itemprop="image">
						<span class="ie-overlay-hack"></span>
								</a>
	
	<div class="text-block ">
		<h2>
			<a href="http://thesportsdaily.com/category/featured/" class="category" itemprop="articleSection">Featured</a>					</h2>

		<p><a data-track="featuredstories" href="https://thesportsdaily.com/2018/08/30/ten-nfl-training-camp-battles-won-by-rookies/" title="Ten NFL Training Camp Battles Won By Rookies" itemprop="url" >Ten NFL Training Camp Battles Won By Rookies</a></p>

			</div>
</article>

<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
			<a href="https://thesportsdaily.com/2018/08/03/nba-powerless-rankings-offseason-wrap-up/" data-track="featuredstories" title="NBA Powerless Rankings: Offseason Wrap-up" class="link fixed-height-img-holder short responsiveshort " rel="nofollow" style="background-image: url('https://thesportsdailydigital.files.wordpress.com/2018/08/usatsi_10679785_168384702_lowres.jpg?w=295&#038;h=231&#038;crop=1');" itemprop="url" >
			<img src="https://thesportsdailydigital.files.wordpress.com/2018/08/usatsi_10679785_168384702_lowres.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="NBA Powerless Rankings: Offseason Wrap-up" itemprop="image">
						<span class="ie-overlay-hack"></span>
								</a>
	
	<div class="text-block ">
		<h2>
			<a href="http://thesportsdaily.com/category/the-lottery-mafia/" class="category" itemprop="articleSection">The Lottery Mafia</a>					</h2>

		<p><a data-track="featuredstories" href="https://thesportsdaily.com/2018/08/03/nba-powerless-rankings-offseason-wrap-up/" title="NBA Powerless Rankings: Offseason Wrap-up" itemprop="url" >NBA Powerless Rankings: Offseason Wrap-up</a></p>

			</div>
</article>
			</div>
		</div>

	</div>
<div class="container single-related" id="rcjsload_bf5c5f"></div><div class="container single-related container--comments">
	<div class="heading-small">
		<h2>Comments</h2>
	</div>

	<div id="comments" class="comments-area">
	<div data-spotim-module="recirculation" data-spot-id="sp_nPbXdnQE"></div>
		<script async src="https://recirculation.spot.im/spot/sp_nPbXdnQE"></script>
	<script async src="https://launcher.spot.im/spot/sp_nPbXdnQE"
		data-spotim-module="spotim-launcher"
		data-post-url="https://thesportsdaily.com/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/"
		data-post-id="840780"
	></script>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>More Sports</h2>
	</div>
	<script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_native", slotName: "/7103/SMG_TheSportsDaily/native/sports/general", sizes : [[640,170],[3,1]] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_native' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_native"] = googletag.defineSlot("/7103/SMG_TheSportsDaily/native/sports/general", [[640,170],[3,1]], "acm-ad-tag-lawrence_dfp_desktop_native").addService(googletag.pubads().setTargeting('kw',["Josh Okogie","Kieta Bates-Diop","Minnesota Timberwolves","NBA","rookie","Timberwolves","Aaron Herbst"]).setTargeting('category',["Timberwolves"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["native"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_native' );
												bidManager.requestBid( 'lawrence_dfp_desktop_native' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_native' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_native' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/wild-fans-speak-2018-19-edition-season-preview-part-1-of-3/"
						title="Wild Fans Speak 2018-19 Edition: Season Preview, Part 1 of 3"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thesportsdailydigital.files.wordpress.com/2018/08/usatsi_10713295.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thesportsdailydigital.files.wordpress.com/2018/08/usatsi_10713295.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Wild Fans Speak 2018-19 Edition: Season Preview, Part 1 of 3" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="https://thesportsdaily.com/2018/09/02/wild-fans-speak-2018-19-edition-season-preview-part-1-of-3/"
								title="Wild Fans Speak 2018-19 Edition: Season Preview, Part 1 of 3"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

									</div>

			
			<div class="mobile-date">
				19m			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thesportsdaily.com/category/nhl/" class="category" itemprop="articleSection">NHL</a>						<span class="block__time block__time--mobile">19m ago</span>					</h4>
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/wild-fans-speak-2018-19-edition-season-preview-part-1-of-3/"
						title="Wild Fans Speak 2018-19 Edition: Season Preview, Part 1 of 3"
						itemprop="url" 						>
							Wild Fans Speak 2018-19 Edition: Season Preview, Part 1 of 3					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 2, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thesportsdaily.com/author/stateofhckynews/" title="Posts by Derek Felska" class="author url fn" rel="author">Derek Felska</a>													</span>
					</p>
				</footer>

				<p>If there is anything I&#8217;ve learned from blogging is that fans represent their own sort of community.  Whether they band together on (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/watch-doug-pederson-gets-testy-with-reporter-over-starting-qb-question/"
						title="Watch: Doug Pederson gets testy with reporter over starting QB question"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thesportsdailydigital.files.wordpress.com/2018/09/screen-shot-2018-09-02-at-4-41-10-pm.png?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thesportsdailydigital.files.wordpress.com/2018/09/screen-shot-2018-09-02-at-4-41-10-pm.png?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Watch: Doug Pederson gets testy with reporter over starting QB question" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="https://thesportsdaily.com/2018/09/02/watch-doug-pederson-gets-testy-with-reporter-over-starting-qb-question/"
								title="Watch: Doug Pederson gets testy with reporter over starting QB question"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

									</div>

			
			<div class="mobile-date">
				20m			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thesportsdaily.com/category/eagles-eye-blog/" class="category" itemprop="articleSection">Eagles</a>						<span class="block__time block__time--mobile">20m ago</span>					</h4>
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/watch-doug-pederson-gets-testy-with-reporter-over-starting-qb-question/"
						title="Watch: Doug Pederson gets testy with reporter over starting QB question"
						itemprop="url" 						>
							Watch: Doug Pederson gets testy with reporter over starting QB question					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 2, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thesportsdaily.com/author/themattbirch/" title="Posts by Matt Birch" class="author url fn" rel="author">Matt Birch</a>													</span>
					</p>
				</footer>

				<p>Eagles head coach Doug Pederson is no longer interested in answering questions about who&#8217;ll be starting under center for the team (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/packers-taking-big-risk-with-only-2-rbs-on-the-roster-html-bkurt11/"
						title="Packers Taking Big Risk with Only 2 RBs on the Roster"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10440938.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10440938.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Packers Taking Big Risk with Only 2 RBs on the Roster" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="https://thesportsdaily.com/2018/09/02/packers-taking-big-risk-with-only-2-rbs-on-the-roster-html-bkurt11/"
								title="Packers Taking Big Risk with Only 2 RBs on the Roster"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

									</div>

			
			<div class="mobile-date">
				1hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thesportsdaily.com/category/nfl/" class="category" itemprop="articleSection">NFL</a>						<span class="block__time block__time--mobile">1hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/packers-taking-big-risk-with-only-2-rbs-on-the-roster-html-bkurt11/"
						title="Packers Taking Big Risk with Only 2 RBs on the Roster"
						itemprop="url" 						>
							Packers Taking Big Risk with Only 2 RBs on the Roster					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 2, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thesportsdaily.com/author/sportshistoryguy22/" title="Posts by Gil Martin" class="author url fn" rel="author">Gil Martin</a>													</span>
					</p>
				</footer>

				<p>The Green Bay Packers have made their final cuts and the team is down to the 53-man player limit. New GM Brian Gutekunst made some bold and (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/9-2-18-game-preview-new-york-mets-at-san-francisco-giants-m1d1/"
						title="9/2/18 Game Preview: New York Mets at San Francisco Giants"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_11175563.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_11175563.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="9/2/18 Game Preview: New York Mets at San Francisco Giants" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="https://thesportsdaily.com/2018/09/02/9-2-18-game-preview-new-york-mets-at-san-francisco-giants-m1d1/"
								title="9/2/18 Game Preview: New York Mets at San Francisco Giants"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

									</div>

			
			<div class="mobile-date">
				1hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thesportsdaily.com/category/metstradamus-blog/" class="category" itemprop="articleSection">Mets</a>						<span class="block__time block__time--mobile">1hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/9-2-18-game-preview-new-york-mets-at-san-francisco-giants-m1d1/"
						title="9/2/18 Game Preview: New York Mets at San Francisco Giants"
						itemprop="url" 						>
							9/2/18 Game Preview: New York Mets at San Francisco Giants					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 2, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thesportsdaily.com/author/phillipsm331/" title="Posts by Mike Phillips" class="author url fn" rel="author">Mike Phillips</a>													</span>
					</p>
				</footer>

				<p>VThe New York Mets (60-75) got off to a good start in September by evening their series with the San Francisco Giants (68-69) yesterday (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/the-rock-to-return-for-wwe-smackdown-1000-twake11/"
						title="The Rock To Return For WWE &#039;Smackdown&#039; 1000?"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thesportsdailydigital.files.wordpress.com/2018/09/rock.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thesportsdailydigital.files.wordpress.com/2018/09/rock.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="The Rock To Return For WWE &#039;Smackdown&#039; 1000?" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="https://thesportsdaily.com/2018/09/02/the-rock-to-return-for-wwe-smackdown-1000-twake11/"
								title="The Rock To Return For WWE &#039;Smackdown&#039; 1000?"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

									</div>

			
			<div class="mobile-date">
				2hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thesportsdaily.com/category/the-floor-seat/" class="category" itemprop="articleSection">The Floor Seat</a>						<span class="block__time block__time--mobile">2hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/the-rock-to-return-for-wwe-smackdown-1000-twake11/"
						title="The Rock To Return For WWE &#039;Smackdown&#039; 1000?"
						itemprop="url" 						>
							The Rock To Return For WWE &#039;Smackdown&#039; 1000?					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 2, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thesportsdaily.com/author/traviswakeman/" title="Posts by Travis Wakeman" class="author url fn" rel="author">Travis Wakeman</a>													</span>
					</p>
				</footer>

				<p>The Rock&#8217;s next WWE appearance may be coming soon. &#8216;SmackDown&#8217; will celebrate episode No. 1,000 in just over (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/why-aaron-boone-gave-umpire-nic-lentz-exactly-what-he-deserved-ddech11/"
						title="Aaron Boone Gave Umpire Nic Lentz Exactly What He Deserved"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10952115.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_10952115.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Aaron Boone Gave Umpire Nic Lentz Exactly What He Deserved" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="https://thesportsdaily.com/2018/09/02/why-aaron-boone-gave-umpire-nic-lentz-exactly-what-he-deserved-ddech11/"
								title="Aaron Boone Gave Umpire Nic Lentz Exactly What He Deserved"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://thesportsdaily.com/2018/09/02/why-aaron-boone-gave-umpire-nic-lentz-exactly-what-he-deserved-ddech11/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="https://thesportsdaily.com/2018/09/02/why-aaron-boone-gave-umpire-nic-lentz-exactly-what-he-deserved-ddech11/"
			title="Aaron Boone Gave Umpire Nic Lentz Exactly What He Deserved"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>322</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thesportsdaily.com/category/new-york-yankees/" class="category" itemprop="articleSection">Yankees</a>						<span class="block__time block__time--mobile">3hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/why-aaron-boone-gave-umpire-nic-lentz-exactly-what-he-deserved-ddech11/"
						title="Aaron Boone Gave Umpire Nic Lentz Exactly What He Deserved"
						itemprop="url" 						>
							Aaron Boone Gave Umpire Nic Lentz Exactly What He Deserved					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 2, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thesportsdaily.com/author/yankeefandan/" title="Posts by Dan Dechenaux" class="author url fn" rel="author">Dan Dechenaux</a>													</span>
					</p>
				</footer>

				<p>That a boy Aaron! It&#8217;s time Major League Baseball umpires were put in their place. And your one game suspension was well worth making (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/look-kanye-west-says-bears-will-go-to-the-super-bowl-after-khalil-mack-trade-html-h1p1/"
						title="Look: Kanye West says Bears will go to the Super Bowl after Khalil Mack trade"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thesportsdailydigital.files.wordpress.com/2016/02/509642162.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thesportsdailydigital.files.wordpress.com/2016/02/509642162.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Look: Kanye West says Bears will go to the Super Bowl after Khalil Mack trade" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="https://thesportsdaily.com/2018/09/02/look-kanye-west-says-bears-will-go-to-the-super-bowl-after-khalil-mack-trade-html-h1p1/"
								title="Look: Kanye West says Bears will go to the Super Bowl after Khalil Mack trade"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

									</div>

			
			<div class="mobile-date">
				4hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thesportsdaily.com/category/soldier-field-salute/" class="category" itemprop="articleSection">Bears</a>						<span class="block__time block__time--mobile">4hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/look-kanye-west-says-bears-will-go-to-the-super-bowl-after-khalil-mack-trade-html-h1p1/"
						title="Look: Kanye West says Bears will go to the Super Bowl after Khalil Mack trade"
						itemprop="url" 						>
							Look: Kanye West says Bears will go to the Super Bowl after Khalil Mack trade					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 2, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thesportsdaily.com/author/phadesportsmoll/" title="Posts by Brandon Molleur" class="author url fn" rel="author">Brandon Molleur</a>													</span>
					</p>
				</footer>

				<p>If there is anyone who isn&#8217;t shy to hot takes, it would be Kanye West. His newest head turning take has nothing to do with rap music. (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/report-chargers-to-sign-te-antonio-gates-html-h1p1/"
						title="Report: Chargers to sign TE Antonio Gates"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thesportsdailydigital.files.wordpress.com/2018/08/usatsi_10217700.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thesportsdailydigital.files.wordpress.com/2018/08/usatsi_10217700.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Report: Chargers to sign TE Antonio Gates" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="https://thesportsdaily.com/2018/09/02/report-chargers-to-sign-te-antonio-gates-html-h1p1/"
								title="Report: Chargers to sign TE Antonio Gates"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

									</div>

			
			<div class="mobile-date">
				4hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thesportsdaily.com/category/the-bolts-blog/" class="category" itemprop="articleSection">Chargers</a>						<span class="block__time block__time--mobile">4hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/report-chargers-to-sign-te-antonio-gates-html-h1p1/"
						title="Report: Chargers to sign TE Antonio Gates"
						itemprop="url" 						>
							Report: Chargers to sign TE Antonio Gates					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 2, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thesportsdaily.com/author/phadesportsmoll/" title="Posts by Brandon Molleur" class="author url fn" rel="author">Brandon Molleur</a>													</span>
					</p>
				</footer>

				<p>After much speculation, it looks like there will be a reunion between Antonio Gates and the Chargers franchise. There were expectations that (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/your-morning-dump-where-the-lakers-make-a-competent-move-and-we-like-it/"
						title="Your Morning Dump... Where the Lakers make a competent move (and we like it)"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_9854097.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_9854097.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Your Morning Dump... Where the Lakers make a competent move (and we like it)" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="https://thesportsdaily.com/2018/09/02/your-morning-dump-where-the-lakers-make-a-competent-move-and-we-like-it/"
								title="Your Morning Dump... Where the Lakers make a competent move (and we like it)"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://thesportsdaily.com/2018/09/02/your-morning-dump-where-the-lakers-make-a-competent-move-and-we-like-it/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="https://thesportsdaily.com/2018/09/02/your-morning-dump-where-the-lakers-make-a-competent-move-and-we-like-it/"
			title="Your Morning Dump... Where the Lakers make a competent move (and we like it)"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>261</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thesportsdaily.com/category/boston-celtics/" class="category" itemprop="articleSection">Celtics</a>						<span class="block__time block__time--mobile">6hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/your-morning-dump-where-the-lakers-make-a-competent-move-and-we-like-it/"
						title="Your Morning Dump... Where the Lakers make a competent move (and we like it)"
						itemprop="url" 						>
							Your Morning Dump... Where the Lakers make a competent move (and we like it)					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 2, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thesportsdaily.com/author/redsarmy/" title="Posts by John Karalis" class="author url fn" rel="author">John Karalis</a>													</span>
					</p>
				</footer>

				<p><em>Every morning, we compile the links of the day and dump them here… highlighting the big story line. Because there’s nothing (&#8230;)</em></p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/pittsburgh-pirates-trades-takeaways-pbd11/"
						title="Three Takeaways from Pirates trades"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_11092642.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_11092642.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Three Takeaways from Pirates trades" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="mostrecent"
								href="https://thesportsdaily.com/2018/09/02/pittsburgh-pirates-trades-takeaways-pbd11/"
								title="Three Takeaways from Pirates trades"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://thesportsdaily.com/2018/09/02/pittsburgh-pirates-trades-takeaways-pbd11/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="https://thesportsdaily.com/2018/09/02/pittsburgh-pirates-trades-takeaways-pbd11/"
			title="Three Takeaways from Pirates trades"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>76</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="http://thesportsdaily.com/category/mlb/" class="category" itemprop="articleSection">MLB</a>						<span class="block__time block__time--mobile">6hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://thesportsdaily.com/2018/09/02/pittsburgh-pirates-trades-takeaways-pbd11/"
						title="Three Takeaways from Pirates trades"
						itemprop="url" 						>
							Three Takeaways from Pirates trades					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">September 2, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://thesportsdaily.com/author/noahhiles95/" title="Posts by Noah Hiles" class="author url fn" rel="author">Noah Hiles</a>													</span>
					</p>
				</footer>

				<p>In the late hours of Friday night Pittsburgh Pirates general manager Neal Huntington pulled off two quick trades that sent veteran (&#8230;)</p>

				
				
			</div>
		</article>
	</div>
<div class="social-cta container column">

	<h2 class="social-cta__header">
		Stalk us...	</h2>

			<div class="social-cta__column social-cta__column--social">

			<h3 class="social-cta__type social-cta__type--social">Social</h3>
			<span class="social-cta__desc social-cta__desc--social">
				Add some spice to your feed.			</span>

							<a
					href="https://www.facebook.com/SportsDailyBlog/"
					class="social-cta__button social-cta__button--facebook"
					target="_blank"
				>Like The Sports Daily</a>
			
							<a
					href="https://twitter.com/SportsDailyBlog"
					class="social-cta__button social-cta__button--twitter"
					target="_blank"
				>Follow The Sports Daily</a>
			
		</div>
	
	
	
</div>
<a href="http://thesportsdaily.com/category/howlin-t-wolf/" class="article__back">More Timberwolves</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		
			<div class="widget sidebar-ad top">
				<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>			</div>

		
		
		<div class="widget_text widget widget_custom_html" id="custom_html-5"><div class="heading-small"><h2>Table of Contents</h2></div><div class="textwidget custom-html-widget"><a href="https://thesportsdaily.com/2017/01/01/about-howlin-twolf/">About Howlin' T-Wolf</a><p>
	<a href="https://thesportsdaily.com/category/howlin-t-wolf-fan-mail/">Fan Mail</a>
</p>
<p>
	<a href="https://thesportsdaily.com/category/howlin-t-wolf-fan-reactions/">Fan Reactions</a>
</p></div></div><div class="widget widget--featured widget--box" id="featured_widget-4"><div class="heading-small"><h2>Featured Story</h2></div><article class="block" itemscope="" itemtype="http://schema.org/NewsArticle">

			<a
			style="background-image:url('https://thesportsdailydigital.files.wordpress.com/2018/09/usatsi_11160186.jpg?w=300');"
			data-track="mostshared"
			href="https://thesportsdaily.com/2018/09/01/the-10-best-mlb-players-in-august-cmb11/"
			title="The 10 best MLB players in August"
			class="img-holder"
			rel="nofollow"
			itemprop="url"
		>
					</a>
	
	<div class="text-block">

		
		<p><a
			data-track="mostshared"
			href="https://thesportsdaily.com/2018/09/01/the-10-best-mlb-players-in-august-cmb11/"
			title="The 10 best MLB players in August"
			itemprop="url"
		>The 10 best MLB players in August</a></p>

	</div>
</article>
</div><div class="widget widget--featured widget--box" id="featured_widget-3"><div class="heading-small"><h2>Trending Now</h2></div><article class="block" itemscope="" itemtype="http://schema.org/NewsArticle">

			<a
			style="background-image:url('https://thesportsdailydigital.files.wordpress.com/2018/09/screen-shot-2018-09-02-at-1-16-23-am.png?w=300');"
			data-track="mostshared"
			href="https://thesportsdaily.com/2018/09/01/angry-nick-saban-goes-off-on-bama-player-while-up-34-0-video/"
			title="Angry Nick Saban goes off on Bama player while up 34-0 (Video)"
			class="img-holder"
			rel="nofollow"
			itemprop="url"
		>
					</a>
	
	<div class="text-block">

					<h2>57 shares</h2>
		
		<p><a
			data-track="mostshared"
			href="https://thesportsdaily.com/2018/09/01/angry-nick-saban-goes-off-on-bama-player-while-up-34-0-video/"
			title="Angry Nick Saban goes off on Bama player while up 34-0 (Video)"
			itemprop="url"
		>Angry Nick Saban goes off on Bama player while up 34-0 (Video)</a></p>

	</div>
</article>
</div><div class="widget_text widget widget_custom_html" id="custom_html-11"><div class="heading-small"><h2>Write For Us</h2></div><div class="textwidget custom-html-widget"><a href="http://thesportsdaily.com/interested-in-joining-the-sports-daily-network/"><img src="https://thesportsdailydigital.files.wordpress.com/2018/05/write31.png"></a></div></div><div class="widget widget--featured widget--box" id="featured_widget-2"><div class="heading-small"><h2>Hot Reads</h2></div><article class="block" itemscope="" itemtype="http://schema.org/NewsArticle">

			<a
			style="background-image:url('https://thesportsdailydigital.files.wordpress.com/2018/08/usatsi_11088278.jpg?w=300');"
			data-track="mostshared"
			href="https://thesportsdaily.com/2018/09/01/pittsburgh-pirates-francisco-cervelli-write-off-pbd11/"
			title="Don't write off Francisco Cervelli as a catcher just yet"
			class="img-holder"
			rel="nofollow"
			itemprop="url"
		>
					</a>
	
	<div class="text-block">

		
		<p><a
			data-track="mostshared"
			href="https://thesportsdaily.com/2018/09/01/pittsburgh-pirates-francisco-cervelli-write-off-pbd11/"
			title="Don't write off Francisco Cervelli as a catcher just yet"
			itemprop="url"
		>Don't write off Francisco Cervelli as a catcher just yet</a></p>

	</div>
</article>
</div><div class="widget widget--featured widget--box" id="featured_widget-5"><div class="heading-small"><h2>Take a Look</h2></div><article class="block" itemscope="" itemtype="http://schema.org/NewsArticle">

			<a
			style="background-image:url('https://thesportsdailydigital.files.wordpress.com/2018/09/screen-shot-2018-09-02-at-1-51-48-am.png?w=300');"
			data-track="mostshared"
			href="https://thesportsdaily.com/2018/09/01/watch-joe-west-confiscates-phillies-pitcher-austin-davis-scouting-sheet-during-game/"
			title="Watch: Joe West confiscates Phillies pitcher Austin Davis' scouting sheet during game"
			class="img-holder"
			rel="nofollow"
			itemprop="url"
		>
					</a>
	
	<div class="text-block">

		
		<p><a
			data-track="mostshared"
			href="https://thesportsdaily.com/2018/09/01/watch-joe-west-confiscates-phillies-pitcher-austin-davis-scouting-sheet-during-game/"
			title="Watch: Joe West confiscates Phillies pitcher Austin Davis' scouting sheet during game"
			itemprop="url"
		>Watch: Joe West confiscates Phillies pitcher Austin Davis' scouting sheet during game</a></p>

	</div>
</article>
</div>
		
			<div class="widget sidebar-ad bottom">
				<script type="text/javascript">bidManager.addBidSlot({ slotID: "acm-ad-tag-lawrence_dfp_desktop_bottom_300x250", slotName: "/7103/SMG_TheSportsDaily/300x250_2a/sports/general", sizes : [[300,250],[300,600]] });</script><div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>
					(function ($, win, doc) {
						$(doc).ready(function () {
							var lazyLoadAd = function (event) {
								if( ! bottomAdMobileRendered ){
									var container = $( '#acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' ).offset(),
									    adLoadPoint = $( window ).scrollTop() + $( window ).height();

									if ( adLoadPoint >= container.top ) {
										$( win ).off( 'scroll', lazyLoadAd );
										googletag_cmd_push( function() {window["lawrence_dfp_desktop_bottom_300x250"] = googletag.defineSlot("/7103/SMG_TheSportsDaily/300x250_2a/sports/general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_bottom_300x250").addService(googletag.pubads().setTargeting('kw',["Josh Okogie","Kieta Bates-Diop","Minnesota Timberwolves","NBA","rookie","Timberwolves","Aaron Herbst"]).setTargeting('category',["Timberwolves"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_2a"]);
											googletag.display( 'acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' );
												bidManager.requestBid( 'lawrence_dfp_desktop_bottom_300x250' );
										});
									}
								}
							};
							$(win).on('scroll', lazyLoadAd);
						});
						googletag_cmd_push( function() {
							googletag.pubads().addEventListener( 'slotRenderEnded', function( evt ) {
								var cnterDim,
									tagId = evt.slot.getSlotId().getDomId();

								if ( 'acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' === tagId ) {
									cnterDim = evt.size;

									if ( cnterDim instanceof Array ) {
										$( '#acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' ).css({
											width : cnterDim[0],
											height : auto
										});
									}
								}
							});
						});
					})(jQuery, window, document);</script></div>			</div>

		
		
<div id="footer-info">
	<p class="footer__logo">
		<a href="" rel="nofollow" target="_blank">
			<img src="https://thesportsdailydigital.files.wordpress.com/2018/03/wordmark-small.png" alt="The Sports Daily">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-bloguin-footer-menu-container"><ul id="menu-bloguin-footer-menu" class="menu"><li id="menu-item-804137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-804137"><a href="http://thesportsdaily.com/the-sports-daily-staff/">About Us</a></li>
<li id="menu-item-804140" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-804140"><a href="http://thesportsdaily.com/contact-the-sports-daily/">Contact Us</a></li>
<li id="menu-item-804139" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-804139"><a href="http://thesportsdaily.com/advertise-2/">Advertise With Us</a></li>
<li id="menu-item-804138" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-804138"><a href="http://thesportsdaily.com/interested-in-joining-the-sports-daily-network/">Write For Us</a></li>
<li id="menu-item-804136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-804136"><a href="http://thesportsdaily.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thesportsdaily.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "More Information";
		var footer_collapse_text = "Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	
	<!-- wpcom_wp_footer -->
<script type="text/javascript">
(function() {
var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
var rcel = document.createElement("script");
rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
rcel.type = 'text/javascript';
rcel.src = "https://trends.revcontent.com/serve.js.php?w=93354&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
rcel.async = true;
var rcds = document.getElementById("rcjsload_bf5c5f"); rcds.appendChild(rcel);
var rcdsLawrence = document.getElementById( "single-related-revcontent-lawrence" );
if ( rcdsLawrence ) {
	rcdsLawrence.style.display = 'block';
}
})();
</script>
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://thesportsdailydigital.files.wordpress.com/2018/03/wordmark-small.png" alt="The Sports Daily">
				<a class="mobile-nav__breadcrumb" href="http://thesportsdaily.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
			<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/SportsDailyBlog/" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/SportsDailyBlog" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--nfl mobile-nav__item--parent"><a href="http://thesportsdaily.com/category/nfl/">NFL</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--afc-east mobile-nav__item--parent"><a href="#">AFC East</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--dolphins"><a href="http://thesportsdaily.com/category/phins-phocus/">Dolphins</a></li>
		<li class="mobile-nav__item mobile-nav__item--jets"><a href="http://thesportsdaily.com/category/new-york-sack-exchange/">Jets</a></li>
		<li class="mobile-nav__item mobile-nav__item--patriots"><a href="http://thesportsdaily.com/category/foxboro-blog/">Patriots</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--afc-north mobile-nav__item--parent"><a href="#">AFC North</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--bengals"><a href="http://thesportsdaily.com/category/bengals-brigade/">Bengals</a></li>
		<li class="mobile-nav__item mobile-nav__item--browns"><a href="http://thesportsdaily.com/category/browns-pound/">Browns</a></li>
		<li class="mobile-nav__item mobile-nav__item--ravens"><a href="http://thesportsdaily.com/category/ravens-football-machine/">Ravens</a></li>
		<li class="mobile-nav__item mobile-nav__item--steelers"><a href="http://thesportsdaily.com/category/pittsburgh-steelers/">Steelers</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--afc-south mobile-nav__item--parent"><a href="#">AFC South</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--colts"><a href="http://thesportsdaily.com/category/colts-authority/">Colts</a></li>
		<li class="mobile-nav__item mobile-nav__item--jaguars"><a href="http://thesportsdaily.com/category/the-jaggernaut/">Jaguars</a></li>
		<li class="mobile-nav__item mobile-nav__item--texans"><a href="http://thesportsdaily.com/category/texans-tribune/">Texans</a></li>
		<li class="mobile-nav__item mobile-nav__item--titans"><a href="http://thesportsdaily.com/category/total-titans/">Titans</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--afc-west mobile-nav__item--parent"><a href="#">AFC West</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--broncos"><a href="http://thesportsdaily.com/category/mile-high-broncos/">Broncos</a></li>
		<li class="mobile-nav__item mobile-nav__item--chargers"><a href="http://thesportsdaily.com/category/the-bolts-blog/">Chargers</a></li>
		<li class="mobile-nav__item mobile-nav__item--chiefs"><a href="http://thesportsdaily.com/category/chiefs-daily/">Chiefs</a></li>
		<li class="mobile-nav__item mobile-nav__item--raiders"><a href="http://thesportsdaily.com/category/tfds-sports/">Raiders</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--nfc-east mobile-nav__item--parent"><a href="#">NFC East</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--cowboys"><a href="http://thesportsdaily.com/category/dallas-cowboys/">Cowboys</a></li>
		<li class="mobile-nav__item mobile-nav__item--eagles"><a href="http://thesportsdaily.com/category/eagles-eye-blog/">Eagles</a></li>
		<li class="mobile-nav__item mobile-nav__item--giants"><a href="http://thesportsdaily.com/category/new-york-giants/">Giants</a></li>
		<li class="mobile-nav__item mobile-nav__item--redskins"><a href="http://thesportsdaily.com/category/redskins-hog-heaven/">Redskins</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--nfc-north mobile-nav__item--parent"><a href="#">NFC North</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--bears"><a href="http://thesportsdaily.com/category/soldier-field-salute/">Bears</a></li>
		<li class="mobile-nav__item mobile-nav__item--lions"><a href="http://thesportsdaily.com/category/outside-the-lions/">Lions</a></li>
		<li class="mobile-nav__item mobile-nav__item--packers"><a href="http://thesportsdaily.com/category/packers-press/">Packers</a></li>
		<li class="mobile-nav__item mobile-nav__item--vikings"><a href="http://thesportsdaily.com/category/vikings-digital-diaries/">Vikings</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--nfc-south mobile-nav__item--parent"><a href="#">NFC South</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--buccaneers"><a href="http://thesportsdaily.com/category/tampa-bay-buccaneers/">Buccaneers</a></li>
		<li class="mobile-nav__item mobile-nav__item--falcons"><a href="http://thesportsdaily.com/category/grits-blitz/">Falcons</a></li>
		<li class="mobile-nav__item mobile-nav__item--panthers"><a href="http://thesportsdaily.com/category/panther-rules/">Panthers</a></li>
		<li class="mobile-nav__item mobile-nav__item--saints"><a href="http://thesportsdaily.com/category/the-saints-nation/">Saints</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--nfc-west mobile-nav__item--parent"><a href="#">NFC West</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--49ers"><a href="http://thesportsdaily.com/category/the-red-and-gold/">49ers</a></li>
		<li class="mobile-nav__item mobile-nav__item--cardinals"><a href="http://thesportsdaily.com/category/cardinals-camp/">Cardinals</a></li>
		<li class="mobile-nav__item mobile-nav__item--rams"><a href="http://thesportsdaily.com/category/rams-ramblings/">Rams</a></li>
		<li class="mobile-nav__item mobile-nav__item--seahawks"><a href="http://thesportsdaily.com/category/seahawk-addicts/">Seahawks</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--general mobile-nav__item--parent"><a href="#">General</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--guru-qb"><a href="http://thesportsdaily.com/category/guru-qb/">Guru QB</a></li>
	</ul>
</li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--nba mobile-nav__item--parent"><a href="http://thesportsdaily.com/category/nba/">NBA</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--featured mobile-nav__item--parent"><a href="#">FEATURED</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--cowbell-kingdom"><a href="http://thesportsdaily.com/category/cowbell-kingdom/">Cowbell Kingdom</a></li>
		<li class="mobile-nav__item mobile-nav__item--reds-army"><a href="http://thesportsdaily.com/category/reds-army/">Red's Army</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--atlantic mobile-nav__item--parent"><a href="#">Atlantic</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--76ers"><a href="http://thesportsdaily.com/category/philadelphia-76ers/">76ers</a></li>
		<li class="mobile-nav__item mobile-nav__item--celtics"><a href="http://thesportsdaily.com/category/boston-celtics/">Celtics</a></li>
		<li class="mobile-nav__item mobile-nav__item--knicks"><a href="http://thesportsdaily.com/category/new-york-knicks/">Knicks</a></li>
		<li class="mobile-nav__item mobile-nav__item--nets"><a href="http://thesportsdaily.com/category/brooklyn-balling/">Nets</a></li>
		<li class="mobile-nav__item mobile-nav__item--raptors"><a href="http://thesportsdaily.com/category/hoop-heads-north/">Raptors</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--central mobile-nav__item--parent"><a href="#">Central</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--bucks"><a href="http://thesportsdaily.com/category/milwaukee-bucks/">Bucks</a></li>
		<li class="mobile-nav__item mobile-nav__item--bulls"><a href="http://thesportsdaily.com/category/chicago-bulls/">Bulls</a></li>
		<li class="mobile-nav__item mobile-nav__item--cavaliers"><a href="http://thesportsdaily.com/category/cleveland-cavaliers/">Cavaliers</a></li>
		<li class="mobile-nav__item mobile-nav__item--pacers"><a href="http://thesportsdaily.com/category/pacers-pulse/">Pacers</a></li>
		<li class="mobile-nav__item mobile-nav__item--pistons"><a href="http://thesportsdaily.com/category/detroit-pistons/">Pistons</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--southeast mobile-nav__item--parent"><a href="#">Southeast</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--hawks"><a href="http://thesportsdaily.com/category/atlanta-hawks/">Hawks</a></li>
		<li class="mobile-nav__item mobile-nav__item--heat"><a href="http://thesportsdaily.com/category/miami-heat/">Heat</a></li>
		<li class="mobile-nav__item mobile-nav__item--hornets"><a href="http://thesportsdaily.com/category/trade-street-post/">Hornets</a></li>
		<li class="mobile-nav__item mobile-nav__item--magic"><a href="http://thesportsdaily.com/category/orlando-magic/">Magic</a></li>
		<li class="mobile-nav__item mobile-nav__item--wizards"><a href="http://thesportsdaily.com/category/hoop-district/">Wizards</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--northwest mobile-nav__item--parent"><a href="#">Northwest</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--jazz"><a href="http://thesportsdaily.com/category/utah-jazz/">Jazz</a></li>
		<li class="mobile-nav__item mobile-nav__item--nuggets"><a href="http://thesportsdaily.com/category/denver-nuggets/">Nuggets</a></li>
		<li class="mobile-nav__item mobile-nav__item--thunder"><a href="http://thesportsdaily.com/category/oklahoma-city-thunder/">Thunder</a></li>
		<li class="mobile-nav__item mobile-nav__item--timberwolves"><a href="http://thesportsdaily.com/category/howlin-t-wolf/">Timberwolves</a></li>
		<li class="mobile-nav__item mobile-nav__item--trailblazers"><a href="http://thesportsdaily.com/category/portland-trailblazers/">Trailblazers</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--southwest mobile-nav__item--parent"><a href="#">Southwest</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--grizzlies"><a href="http://thesportsdaily.com/category/memphis-grizzlies/">Grizzlies</a></li>
		<li class="mobile-nav__item mobile-nav__item--mavericks"><a href="http://thesportsdaily.com/category/dallas-mavericks/">Mavericks</a></li>
		<li class="mobile-nav__item mobile-nav__item--pelicans"><a href="http://thesportsdaily.com/category/pelicans-eye-view/">Pelicans</a></li>
		<li class="mobile-nav__item mobile-nav__item--rockets"><a href="http://thesportsdaily.com/category/houston-rockets/">Rockets</a></li>
		<li class="mobile-nav__item mobile-nav__item--spurs"><a href="http://thesportsdaily.com/category/san-antonio-spurs/">Spurs</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--pacific mobile-nav__item--parent"><a href="#">Pacific</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--clippers"><a href="http://thesportsdaily.com/category/los-angeles-clippers/">Clippers</a></li>
		<li class="mobile-nav__item mobile-nav__item--kings"><a href="http://thesportsdaily.com/category/cow-town-hoops/">Kings</a></li>
		<li class="mobile-nav__item mobile-nav__item--lakers"><a href="http://thesportsdaily.com/category/los-angeles-lakers/">Lakers</a></li>
		<li class="mobile-nav__item mobile-nav__item--suns"><a href="http://thesportsdaily.com/category/phoenix-suns/">Suns</a></li>
		<li class="mobile-nav__item mobile-nav__item--warriors"><a href="http://thesportsdaily.com/category/lets-go-warriors/">Warriors</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--general mobile-nav__item--parent"><a href="#">General</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--hoops-manifesto"><a href="http://thesportsdaily.com/category/hoops-manifesto/">Hoops Manifesto</a></li>
		<li class="mobile-nav__item mobile-nav__item--the-lottery-mafia"><a href="http://thesportsdaily.com/category/the-lottery-mafia/">The Lottery Mafia</a></li>
	</ul>
</li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--mlb mobile-nav__item--parent"><a href="http://thesportsdaily.com/category/mlb/">MLB</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--featured mobile-nav__item--parent"><a href="#">FEATURED</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--pirates-breakdown"><a href="http://thesportsdaily.com/category/pirates-breakdown/">Pirates Breakdown</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--al-east mobile-nav__item--parent"><a href="#">AL East</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--blue-jays"><a href="http://thesportsdaily.com/category/toronto-blue-jays/">Blue Jays</a></li>
		<li class="mobile-nav__item mobile-nav__item--orioles"><a href="http://thesportsdaily.com/category/baltimore-orioles/">Orioles</a></li>
		<li class="mobile-nav__item mobile-nav__item--rays"><a href="http://thesportsdaily.com/category/tampa-bay-rays/">Rays</a></li>
		<li class="mobile-nav__item mobile-nav__item--red-sox"><a href="http://thesportsdaily.com/category/fenway-west/">Red Sox</a></li>
		<li class="mobile-nav__item mobile-nav__item--yankees"><a href="http://thesportsdaily.com/category/new-york-yankees/">Yankees</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--al-central mobile-nav__item--parent"><a href="#">AL Central</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--indians"><a href="http://thesportsdaily.com/category/burning-river-baseball/">Indians</a></li>
		<li class="mobile-nav__item mobile-nav__item--royals"><a href="http://thesportsdaily.com/category/kansas-city-royals/">Royals</a></li>
		<li class="mobile-nav__item mobile-nav__item--tigers"><a href="http://thesportsdaily.com/category/detriot-tigers/">Tigers</a></li>
		<li class="mobile-nav__item mobile-nav__item--twins"><a href="http://thesportsdaily.com/category/twins-target/">Twins</a></li>
		<li class="mobile-nav__item mobile-nav__item--white-sox"><a href="http://thesportsdaily.com/category/grab-some-bench/">White Sox</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--al-west mobile-nav__item--parent"><a href="#">AL West</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--angels"><a href="http://thesportsdaily.com/category/angels-win/">Angels</a></li>
		<li class="mobile-nav__item mobile-nav__item--astros"><a href="http://thesportsdaily.com/category/houston-astros/">Astros</a></li>
		<li class="mobile-nav__item mobile-nav__item--athletics"><a href="http://thesportsdaily.com/category/oakland-athletics/">Athletics</a></li>
		<li class="mobile-nav__item mobile-nav__item--mariners"><a href="http://thesportsdaily.com/category/seattle-mariners/">Mariners</a></li>
		<li class="mobile-nav__item mobile-nav__item--rangers"><a href="http://thesportsdaily.com/category/texas-rangers/">Rangers</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--nl-east mobile-nav__item--parent"><a href="#">NL East</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--braves"><a href="http://thesportsdaily.com/category/atlanta-braves/">Braves</a></li>
		<li class="mobile-nav__item mobile-nav__item--marlins"><a href="http://thesportsdaily.com/category/miami-marlins/">Marlins</a></li>
		<li class="mobile-nav__item mobile-nav__item--mets"><a href="http://thesportsdaily.com/category/metstradamus-blog/">Mets</a></li>
		<li class="mobile-nav__item mobile-nav__item--nationals"><a href="http://thesportsdaily.com/category/washington-nationals/">Nationals</a></li>
		<li class="mobile-nav__item mobile-nav__item--phillies"><a href="http://thesportsdaily.com/category/macho-row/">Phillies</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--nl-central mobile-nav__item--parent"><a href="#">NL Central</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--brewers"><a href="http://thesportsdaily.com/category/the-brewers-bar/">Brewers</a></li>
		<li class="mobile-nav__item mobile-nav__item--cardinals"><a href="http://thesportsdaily.com/category/cards-diaspora/">Cardinals</a></li>
		<li class="mobile-nav__item mobile-nav__item--cubs"><a href="http://thesportsdaily.com/category/chicago-cubs/">Cubs</a></li>
		<li class="mobile-nav__item mobile-nav__item--pirates"><a href="http://thesportsdaily.com/category/pirates-breakdown/">Pirates</a></li>
		<li class="mobile-nav__item mobile-nav__item--reds"><a href="http://thesportsdaily.com/category/redleg-baseball/">Reds</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--nl-west mobile-nav__item--parent"><a href="#">NL West</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--diamondbacks"><a href="http://thesportsdaily.com/category/arizona-diamondbacks/">Diamondbacks</a></li>
		<li class="mobile-nav__item mobile-nav__item--dodgers"><a href="http://thesportsdaily.com/category/los-angeles-dodgers/">Dodgers</a></li>
		<li class="mobile-nav__item mobile-nav__item--giants"><a href="http://thesportsdaily.com/category/the-giants-cove/">Giants</a></li>
		<li class="mobile-nav__item mobile-nav__item--padres"><a href="http://thesportsdaily.com/category/san-diego-padres/">Padres</a></li>
		<li class="mobile-nav__item mobile-nav__item--rockies"><a href="http://thesportsdaily.com/category/colorado-rockies/">Rockies</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--general mobile-nav__item--parent"><a href="#">General</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--chin-music-baseball"><a href="http://thesportsdaily.com/category/chin-music-baseball/">Chin Music Baseball</a></li>
		<li class="mobile-nav__item mobile-nav__item--hall-of-very-good"><a href="http://thesportsdaily.com/category/hall-of-very-good/">Hall of Very Good</a></li>
	</ul>
</li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--nhl mobile-nav__item--parent"><a href="http://thesportsdaily.com/category/nhl/">NHL</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--featured mobile-nav__item--parent"><a href="#">FEATURED</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--the-pensblog"><a href="http://thesportsdaily.com/category/the-pensblog/">The Pensblog</a></li>
		<li class="mobile-nav__item mobile-nav__item--the-oilers-rig"><a href="http://thesportsdaily.com/category/the-oilers-rig/">The Oilers Rig</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--atlantic mobile-nav__item--parent"><a href="#">Atlantic</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--sabres"><a href="http://thesportsdaily.com/category/buffalo-sabres/">Sabres</a></li>
		<li class="mobile-nav__item mobile-nav__item--senators"><a href="http://thesportsdaily.com/category/the-6th-sens/">Senators</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--metropolitan mobile-nav__item--parent"><a href="#">Metropolitan</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--blue-jackets"><a href="http://thesportsdaily.com/category/buckeye-state-hockey/">Blue Jackets</a></li>
		<li class="mobile-nav__item mobile-nav__item--devils"><a href="http://thesportsdaily.com/category/running-with-the-devils/">Devils</a></li>
		<li class="mobile-nav__item mobile-nav__item--islanders"><a href="http://thesportsdaily.com/category/islanders-insight/">Islanders</a></li>
		<li class="mobile-nav__item mobile-nav__item--penguins"><a href="http://thesportsdaily.com/category/the-pensblog/">Penguins</a></li>
		<li class="mobile-nav__item mobile-nav__item--rangers"><a href="http://thesportsdaily.com/category/ny-rangers-blog/">Rangers</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--central mobile-nav__item--parent"><a href="#">Central</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--blues"><a href="http://thesportsdaily.com/category/frozen-notes/">Blues</a></li>
		<li class="mobile-nav__item mobile-nav__item--wild"><a href="http://thesportsdaily.com/category/crease-and-assist/">Wild</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--pacific mobile-nav__item--parent"><a href="#">Pacific</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--kings"><a href="http://thesportsdaily.com/category/the-hockey-kings/">Kings</a></li>
		<li class="mobile-nav__item mobile-nav__item--oilers"><a href="http://thesportsdaily.com/category/the-oilers-rig/">Oilers</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--general mobile-nav__item--parent"><a href="#">General</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--barry-melrose-rocks"><a href="http://thesportsdaily.com/category/barry-melrose-rocks/">Barry Melrose Rocks</a></li>
	</ul>
</li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--combat mobile-nav__item--parent"><a href="http://thesportsdaily.com/category/combat/">COMBAT</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--mma mobile-nav__item--parent"><a href="http://thesportsdaily.com/category/mma/">MMA</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--mma-manifesto"><a href="http://thesportsdaily.com/category/mma-manifesto/">MMA Manifesto</a></li>
		<li class="mobile-nav__item mobile-nav__item--undercard-superstar"><a href="http://thesportsdaily.com/category/undercard-superstar/">Undercard Superstar</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--pro-wrestling mobile-nav__item--parent"><a href="#">PRO WRESTLING</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--the-floor-seat"><a href="http://thesportsdaily.com/category/the-floor-seat/">The Floor Seat</a></li>
		<li class="mobile-nav__item mobile-nav__item--from-the-top-rope"><a href="http://thesportsdaily.com/category/from-the-top-rope/">From the Top Rope</a></li>
	</ul>
</li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--more mobile-nav__item--parent"><a href="#">MORE</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--culture"><a href="http://thesportsdaily.com/category/culture/">CULTURE</a></li>
	<li class="mobile-nav__item mobile-nav__item--media mobile-nav__item--parent"><a href="#">MEDIA</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--fangs-bites"><a href="http://thesportsdaily.com/category/fangs-bites/">Fang's Bites</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--ncaa mobile-nav__item--parent"><a href="http://thesportsdaily.com/category/ncaa/">NCAA</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--north-dakota"><a href="http://thesportsdaily.com/category/goonsworld-blog/">North Dakota</a></li>
		<li class="mobile-nav__item mobile-nav__item--penn-state"><a href="http://thesportsdaily.com/category/nittany-lions-den/">Penn State</a></li>
	</ul>
</li>
	<li class="mobile-nav__item mobile-nav__item--racing"><a href="http://thesportsdaily.com/category/unexpected-pitstop/">RACING</a></li>
	<li class="mobile-nav__item mobile-nav__item--soccer"><a href="http://thesportsdaily.com/category/soccer/">SOCCER</a></li>
	<li class="mobile-nav__item mobile-nav__item--sports-betting"><a href="http://thesportsdaily.com/category/gambling/">SPORTS BETTING</a></li>
	<li class="mobile-nav__item mobile-nav__item--regional mobile-nav__item--parent"><a href="#">REGIONAL</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--left-coast-sports"><a href="http://thesportsdaily.com/category/left-coast-sports/">Left Coast Sports</a></li>
		<li class="mobile-nav__item mobile-nav__item--motor-city-daily"><a href="http://thesportsdaily.com/category/motor-city-daily/">Motor City Daily</a></li>
		<li class="mobile-nav__item mobile-nav__item--total-sports-live"><a href="http://thesportsdaily.com/category/total-sports-live/">Total Sports Live</a></li>
		<li class="mobile-nav__item mobile-nav__item--t-town-sports"><a href="http://thesportsdaily.com/category/t-town-sports/">T Town Sports</a></li>
	</ul>
</li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--contact mobile-nav__item--parent"><a href="http://thesportsdaily.com/contact-the-sports-daily/">CONTACT</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--about"><a href="https://thesportsdaily.com/the-sports-daily-staff/">ABOUT</a></li>
	<li class="mobile-nav__item mobile-nav__item--advertise"><a href="http://thesportsdaily.com/advertise-2/">ADVERTISE</a></li>
	<li class="mobile-nav__item mobile-nav__item--write-for-us"><a href="http://thesportsdaily.com/interested-in-joining-the-sports-daily-network/">WRITE FOR US</a></li>
	<li class="mobile-nav__item mobile-nav__item--partner-sites mobile-nav__item--parent"><a href="#">PARTNER SITES</a>
	<ul class="sub-menu">
		<li class="mobile-nav__item mobile-nav__item--bloguin-media-group"><a href="http://bloguin.com">Bloguin Media Group</a></li>
		<li class="mobile-nav__item mobile-nav__item--sports-media-101"><a href="http://sportsmedia101.com">Sports Media 101</a></li>
		<li class="mobile-nav__item mobile-nav__item--boston-sports-extra"><a href="http://bostonsportsextra.com">Boston Sports Extra</a></li>
	</ul>
</li>
</ul>
</li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-804137" class="mobile-nav__item mobile-nav__item--about-us"><a href="http://thesportsdaily.com/the-sports-daily-staff/">About Us</a></li>
<li id="menu-item-804140" class="mobile-nav__item mobile-nav__item--contact-us"><a href="http://thesportsdaily.com/contact-the-sports-daily/">Contact Us</a></li>
<li id="menu-item-804139" class="mobile-nav__item mobile-nav__item--advertise-with-us"><a href="http://thesportsdaily.com/advertise-2/">Advertise With Us</a></li>
<li id="menu-item-804138" class="mobile-nav__item mobile-nav__item--write-for-us"><a href="http://thesportsdaily.com/interested-in-joining-the-sports-daily-network/">Write For Us</a></li>
<li id="menu-item-804136" class="mobile-nav__item mobile-nav__item--privacy-policy"><a href="http://thesportsdaily.com/privacy-policy/">Privacy Policy</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thesportsdaily.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

	</div>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201835y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/thesportsdailydigital.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/thesportsdailydigital.wordpress.com\/wp-login.php?action=logout&_wpnonce=fa73bd089c","homeURL":"http:\/\/thesportsdaily.com\/","postID":"840780","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"0","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1521806916j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="142507471" />
				<input type="hidden" id="carousel-reblog-blog-url" value="http://thesportsdaily.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="The Sports Daily" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="190ecdf7ce" /><input type="hidden" name="_wp_http_referer" value="/2018/09/02/which-rookie-will-have-the-greatest-immediate-impact/" />		</form>

		<div class="arrow"></div>
	</div>
<link rel='stylesheet' id='all-css-0-3' href='https://s0.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1524699534h&cssminify=yes' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://s1.wp.com/_static/??/wp-content/js/devicepx.js,/wp-content/mu-plugins/likes/queuehandler.js?m=1519172360j'></script>
<script type='text/javascript' src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _LAWRENCE_ADS_EXPORTS = {"right_rail_ad_delay":{"distance":"2000","seconds":"10","active":"1"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiFacebookReferral = "0";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","maxDistance":"1300","medAdHeight":"239","maxDistanceMed":"600","largeAdHeight":"400","maxDistanceLarge":"0","isDesktop":"1","headerHeight":"100"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/thesportsdaily.com\/wp-admin\/admin-ajax.php","nonce":"449fabfff3","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/thesportsdailydigital.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fthesportsdaily.com%2F2018%2F09%2F02%2Fyour-morning-dump-where-the-lakers-make-a-competent-move-and-we-like-it%2F","blog_id":"142507471","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=142507471&v=wpcom&tz=-4&user_id=0&subd=thesportsdailydigital","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJydkt1OwzAMhV+ILCrb4ArxLG5qFWf5KbHT0LcnHSqrtF2svYssfyfHx9ZlUCYGwSBavtAj65EGnRkkdjApByVhMKgta0FwlL3Cn9rOFAMfLL/oDQqOWm2/M6bpYGK8EG4V8EBhKwPdnU+f1eByT4H1q5pBe+UVBHCTkHlqsEWhAENLs0QWcjvRACP1IDXUfTxThy2kfTCkOrN7ahn38KOVrPKFzlNQ1VptZMFUXyqOmFI1zLfaRgVJYC7/UVMwLs9ycxDDzc66/nd2y/Wtux58aSDFzOi0RRnqT2op7FwuFnYo1bsq1PUoVebTfzTn47E5Ne9vJ/sLFOdU/g=='></script>
<script type='text/javascript' src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'142507471','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'142507471','v':'wpcom','tz':'-4','user_id':'0','post':'840780','subd':'thesportsdailydigital'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=142507471&v=wpcomvt&tz=-4&user_id=0&post=840780&subd=thesportsdailydigital&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6K0crU1hILSs9V3hULjBlWEI4dnU4XTkxQ35ENS9hfjBGNzJxampYTHpJPzRbOHBqaFNrR1pQNix4UEdjd1YzW3Z2MWRYL2doR1M2X3ExckMmb0U2cU4lVyxCZVUlZG5LUnhNRVI9NncxcWpnLk5VeGdpfC9bNEpGXVc1OGxSX3UyP0pCQ3hoJjUvZG9oZS89Q2h2d3w='}]);
_stq.push([ 'clickTrackerInit', '142507471', '840780' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
<!--
	generated 75 seconds ago
	generated in 0.414 seconds
	served from batcache in 0.002 seconds
	expires in 225 seconds
-->
